Zoom Newer Version needed 5.9.3 no work xcfe

If you are looking for a specific 64-bit package and you can't find it in any of the 64-bit repos, please post a request for it here
User avatar
francois
Contributor
Contributor
Posts: 6342
Joined: 28 Dec 2010, 14:25
Distribution: xfce plank porteus nemesis
Location: Le printemps, le printemps, le printemps... ... l'hiver s'essoufle.

Zoom Newer Version needed 5.9.3 no work xcfe

Post#31 by francois » 01 Jun 2023, 11:03

@rych:
zoom is booting in my case, I get the interface up and working.
but there might be some problem on the way further tied to pulse audio, booting from command line:

Code: Select all

oot@porteus:/home/guest# zoom-linux
ZoomLauncher started.
Zoom path is: /opt/zoom
cmd line: 
Start subprocess: /opt/zoom/zoom sucessfully,  process pid: 7493 
Can't load/root/.config/zoomus.conf
XDG_RUNTIME_DIR (/run/user/1000) is not owned by us (uid 0), but by uid 1000! (This could e.g. happen if you try to connect to a non-root PulseAudio as a root user, over the native protocol. Don't do that.)
No PulseAudio daemon running, or not running as session daemon.
                             Class      App      Lib Possible Culprit Flags
                resip::Connection      656      656 
                      resip::Data       36       36 
                 resip::DnsResult     1080     1080 
                   resip::Headers        1        1 
          resip::MsgHeaderScanner       40       40 
                resip::SipMessage     5224     5224 
         resip::TransportSelector      896      896 
                     resip::Tuple      128      128 
              resip::UdpTransport     1144     1144 
          resip::GenericIPAddress       28       28 

zoom started.
XDG_RUNTIME_DIR (/run/user/1000) is not owned by us (uid 0), but by uid 1000! (This could e.g. happen if you try to connect to a non-root PulseAudio as a root user, over the native protocol. Don't do that.)
No PulseAudio daemon running, or not running as session daemon.
Something went wrong while running zoom, exit code is 1.
ZoomLauncher exit.
root@porteus:/home/guest# 
I am able to acces the zoom interface but it complains along the process that the session will be insecure.

Solving the error message:

Code: Select all

XDG_RUNTIME_DIR (/run/user/1000) is not owned by us (uid 0), but by uid 1000!
woud be good.

But I wonder if this has to do with my inclusion of root into group to get spman going:

Code: Select all

root@porteus:~# groupadd root
spman to build zoom, openoffice, vlc from sbo
Prendre son temps, profiter de celui qui passe.

beny
Full of knowledge
Full of knowledge
Posts: 1878
Joined: 02 Jan 2011, 11:33
Location: italy

Zoom Newer Version needed 5.9.3 no work xcfe

Post#32 by beny » 01 Jun 2023, 18:16

hi rych i have done the "build" also in porteus and work zoom-linux is a repack of a debian package so nothing is add or removed,if you have a build system you can try on site to build one.

rych
Warlord
Warlord
Posts: 522
Joined: 04 Jan 2014, 04:27
Distribution: Porteus 5.0 x64 OpenBox
Location: NZ
Contact:

Zoom Newer Version needed 5.9.3 no work xcfe

Post#33 by rych » 03 Jun 2023, 09:25

beny wrote:
30 May 2023, 12:10
Hi rych zoom do nothing as root account, do not start
So this seems to be the final answer. Zoom cannot be run under root. They used to have vulnerability in the past so I guess they just forbid this.


One solution that could work unfortunately gives an error:

Code: Select all

root@porteus:/tmp# su guest /opt/zoom/ZoomLauncher
/opt/zoom/ZoomLauncher: /opt/zoom/ZoomLauncher: cannot execute binary file
UPDATE and it finally starts! So, @beny, turns out su has a different syntax when switching to a non-root user. This works:

Code: Select all

root@porteus:~# su -l guest
guest@porteus:~$ cd /tmp/zoom
guest@porteus:/tmp/zoom$ ./ZoomLauncher
ZoomLauncher started.
Zoom path is: /tmp/zoom
cmd line: 
Start subprocess: /tmp/zoom/zoom sucessfully,  process pid: 8158 
Can't load/home/guest/.config/zoomus.conf
No PulseAudio daemon running, or not running as session daemon.
A couple of notes:
1. Signing in through Google doesn't work because guest might not be set-up for GUI work, e.g.,

Code: Select all

/usr/bin/xdg-open: line 881: firefox: command not found

etc. and the stupid lynx won't do etc.
2. Impossible to direct audio to the correct device maybe because "No PulseAudio daemon running..."

But this is a progress! Next post will list the current steps to make zoom run even under root (sort of)!
Last edited by rych on 03 Jun 2023, 10:14, edited 1 time in total.

rych
Warlord
Warlord
Posts: 522
Joined: 04 Jan 2014, 04:27
Distribution: Porteus 5.0 x64 OpenBox
Location: NZ
Contact:

Zoom Newer Version needed 5.9.3 no work xcfe

Post#34 by rych » 03 Jun 2023, 10:08

CURRENT SOLUTION
1. Download the latest zoom binary package from https://zoom.us/download?os=linux by choosing "Other Linux OS" [tar (for Other Linux OS gcc 5.4+) Version 5.14.7 (2928) ] (alternatively, Zoom-5.14.7.2928.glibc2.17-x86_64.AppImage from https://github.com/probonopd/Zoom.AppImage/releases)
DIRECT LINK: https://zoom.us/client/5.14.7.2928/zoom_x86_64.tar.xz

2. Extract the archived zoom folder into /tmp

3. Under the root, we have to switch to a different user. This seems to be the only way as zoom doesn't start under root:

Code: Select all

root@porteus:~# su -l guest
4. Start it to see the login window:

Code: Select all

guest@porteus:~$ cd /tmp/zoom
guest@porteus:/tmp/zoom$ ./ZoomLauncher
ZoomLauncher started.
Zoom path is: /tmp/zoom
cmd line: 
Start subprocess: /tmp/zoom/zoom sucessfully,  process pid: 8158 
Can't load/home/guest/.config/zoomus.conf
No PulseAudio daemon running, or not running as session daemon.

Note that
a.) Signing in through Google may not work if it can't find your browser, e.g.,

Code: Select all

/usr/bin/xdg-open: line 881: firefox: command not found
etc. and the stupid lynx won't do etc.
b.) Currently you may not be able to redirect the audio to a different output probably due to "No PulseAudio daemon running..."

But mostly it is [SOLVED]! Next let's try and solve the "No PulseAudio daemon running..." otherwise there is no Audio. It's stupid zoom doesn't run under root, because under root we probably would not have this problem:

Code: Select all

root@porteus:~# pacmd 
Welcome to PulseAudio 15.0! Use "help" for usage information.
>>>

compared to:

Code: Select all

guest@porteus:~$ pacmd 
No PulseAudio daemon running, or not running as session daemon
We can get past that error by first starting:

Code: Select all

guest@porteus:~$ pavucontrol&
Or play with things like:

Code: Select all

guest@porteus:~$ pulseaudio --check
Also it needs an exclusive access to the output device.

I tried different things, and somehow made Audio work in the end. But damn! I hate zoom not running under root spending days on annoying problems like this
Last edited by rych on 04 Jun 2023, 17:16, edited 1 time in total.

User avatar
francois
Contributor
Contributor
Posts: 6342
Joined: 28 Dec 2010, 14:25
Distribution: xfce plank porteus nemesis
Location: Le printemps, le printemps, le printemps... ... l'hiver s'essoufle.

Zoom Newer Version needed 5.9.3 no work xcfe

Post#35 by francois » 04 Jun 2023, 14:09

Glad to read that you found a solution. On my side I will try to see if the root issue with spman.
Prendre son temps, profiter de celui qui passe.

User avatar
wread
Module Guard
Module Guard
Posts: 1255
Joined: 09 Jan 2011, 18:48
Distribution: Porteus v5.0-kde-64 bits
Location: Santo Domingo
Contact:

Zoom Newer Version needed 5.9.3 no work xcfe

Post#36 by wread » 08 Jun 2023, 01:21

Hi everybody!
Still no luck getting a newer version of zoom...

Even the appimage will not start... that could mean there is something wrong with our Porteus?

We keep hacking, hacking, hacking, until it runs.....

I do hack on ver 5.14.7 every time I dream a possible new hack..,

Tschüss...(say the German!)

P.S. I noticed the magnificent spanish from Beny already! FB Beny :)
Porteus is proud of the FASTEST KDE ever made.....(take akonadi, nepomuk and soprano out and you will have a decent OS).
The Porteus Community never sleeps!

rych
Warlord
Warlord
Posts: 522
Joined: 04 Jan 2014, 04:27
Distribution: Porteus 5.0 x64 OpenBox
Location: NZ
Contact:

Zoom Newer Version needed 5.9.3 no work xcfe

Post#37 by rych » 08 Jun 2023, 06:26

wread wrote:
08 Jun 2023, 01:21
Still no luck getting a newer version of zoom... Even the appimage will not start
Are you logged in under root? Anyway, could you:
1. download the https://zoom.us/client/5.14.7.2928/zoom_x86_64.tar.xz
2. extract under /tmp and cd to /tmp/zoom
3a. guest@porteus:/tmp/zoom$ ./ZoomLauncher -- should work?
3b. root@porteus:/tmp/zoom# ./ZoomLauncher -- won't work?

User avatar
wread
Module Guard
Module Guard
Posts: 1255
Joined: 09 Jan 2011, 18:48
Distribution: Porteus v5.0-kde-64 bits
Location: Santo Domingo
Contact:

Zoom Newer Version needed 5.9.3 no work xcfe

Post#38 by wread » 08 Jun 2023, 14:17

Ok. guys!
The final solution: use Zoom al guest!...that's all :Yahoo!:
Porteus is proud of the FASTEST KDE ever made.....(take akonadi, nepomuk and soprano out and you will have a decent OS).
The Porteus Community never sleeps!

User avatar
wread
Module Guard
Module Guard
Posts: 1255
Joined: 09 Jan 2011, 18:48
Distribution: Porteus v5.0-kde-64 bits
Location: Santo Domingo
Contact:

Zoom Newer Version needed 5.9.3 no work xcfe

Post#39 by wread » 08 Jun 2023, 15:17

Fortunately I was wrong!

Here is my new version of Zoom that runs ok. I have not make any zoom-meeting with it, but presently it is my final solution.....Old William made it again! ..... and it runs as root! ....at least onmy system (KDE Desktop)!

Good luck!
Porteus is proud of the FASTEST KDE ever made.....(take akonadi, nepomuk and soprano out and you will have a decent OS).
The Porteus Community never sleeps!

rych
Warlord
Warlord
Posts: 522
Joined: 04 Jan 2014, 04:27
Distribution: Porteus 5.0 x64 OpenBox
Location: NZ
Contact:

Zoom Newer Version needed 5.9.3 no work xcfe

Post#40 by rych » 09 Jun 2023, 05:48

wread wrote:
08 Jun 2023, 15:17
it runs as root
Not for me. Using your version, GUI logged in as root, zoom-linux or /opt/zoom/ZoomLauncher binary won't start.

But good to know that it does run under root in principle. There must be something else that is "wrong" with my system

User avatar
wread
Module Guard
Module Guard
Posts: 1255
Joined: 09 Jan 2011, 18:48
Distribution: Porteus v5.0-kde-64 bits
Location: Santo Domingo
Contact:

Zoom Newer Version needed 5.9.3 no work xcfe

Post#41 by wread » 09 Jun 2023, 16:26

Hi rych!
Did you try: Application Launcher>Internet>Zoom?

It should work or your system is faulty...

Good luck!
Porteus is proud of the FASTEST KDE ever made.....(take akonadi, nepomuk and soprano out and you will have a decent OS).
The Porteus Community never sleeps!

rych
Warlord
Warlord
Posts: 522
Joined: 04 Jan 2014, 04:27
Distribution: Porteus 5.0 x64 OpenBox
Location: NZ
Contact:

Zoom Newer Version needed 5.9.3 no work xcfe

Post#42 by rych » 10 Jun 2023, 09:10

wread wrote:
09 Jun 2023, 16:26
Did you try: Application Launcher>Internet>Zoom
Great! Of course, how could I forget to try the stupid --no-sandbox -- lots of Apps need it to run under root, zoom just didn't tell us explicitly. Well done! Thank you! I assume that's the only tweak you had to do on top of the official built binary distribution https://zoom.us/usr/bin/client/5.14.7.2 ... _64.tar.xz ? So in future we can just grab the latest binary and it's going work under root with this:

Code: Select all

/usr/bin/zoom-linux --no-sandbox
[SOLVED]

User avatar
wread
Module Guard
Module Guard
Posts: 1255
Joined: 09 Jan 2011, 18:48
Distribution: Porteus v5.0-kde-64 bits
Location: Santo Domingo
Contact:

Zoom Newer Version needed 5.9.3 no work xcfe

Post#43 by wread » 10 Jun 2023, 13:46

Hi rych!

Indeed I tried many versions of zoom to tweak for Porteus...For the present version, I think I used the Slackware version in txz format, modified to suit Porteus, thinking it MUST work, or our system is faulty...

Testing the application with ldd, I could notice some libraries were buit using the system's resources, others though, used the libraries of the application self...in particular libEGL.so gave me the clue! I needed a way to control the build of the running exemplar....without success!

The lightning finally flashed, as I read the program runs ok as guest!.....I remembered I had packed applications that needed the --no-sandbox directive to run as root!

Bingo!

Research Success!
Porteus is proud of the FASTEST KDE ever made.....(take akonadi, nepomuk and soprano out and you will have a decent OS).
The Porteus Community never sleeps!

rych
Warlord
Warlord
Posts: 522
Joined: 04 Jan 2014, 04:27
Distribution: Porteus 5.0 x64 OpenBox
Location: NZ
Contact:

Zoom Newer Version needed 5.9.3 no work xcfe

Post#44 by rych » 12 Jun 2023, 09:24

Final Solution

We turn the latest official zoom binary distribution into an xzm module:

1. Go to https://zoom.us/download and download Linux Type: Arch
(Direct link at the moment is https://zoom.us/client/5.14.10.3738/zoo ... pkg.tar.xz but get the latest version)

2. make a new folder e.g. /tmp/zoom-5.14.10.3738 and extract into it the 2 folders from the archive: /opt and /usr

3. if you intend to run zoom (by Start->Internet->Zoom for example) from under root, then add --no-sandbox in the /tmp/zoom-5.14.10.3738/usr/share/applications/Zoom.desktop

Code: Select all

Exec=/usr/bin/zoom --no-sandbox %U
4. Turn the /tmp/zoom-5.14.10.3738 folder into a zstd module zoom-5.14.10.3738.xzm

Works under root with Audio etc.

Post Reply