[Solved] Include mini-browser Netsurf in the future

New features which should be implemented in Porteus; suggestions are welcome. All questions or problems with testing releases (alpha, beta, or rc) should go in their relevant thread here, rather than the Bug Reports section.
User avatar
francois
Contributor
Contributor
Posts: 5799
Joined: 28 Dec 2010, 14:25
Distribution: xfce plank porteus nemesis
Location: Le printemps, le printemps, le printemps... ... l'hiver s'essoufle.

[Solved] Include mini-browser Netsurf in the future

Post#16 by francois » 15 Jun 2019, 13:46

nanZor:

Your demand for an update-netsurf is legitimate as much as asny other demand of the porteus community users. Let´s see what the developpers have to say about it. There is already palemoon.

Or maybe you could build the update-netsurf yourself based on update-firefox and submit it for the next porteus version. ;)
Prendre son temps, profiter de celui qui passe.

User avatar
Ed_P
Moderator
Moderator
Posts: 5642
Joined: 06 Feb 2013, 22:12
Distribution: 4.0 & 5.0rc2 Cinnamon 64 ISOs
Location: Western NY, USA

[Solved] Include mini-browser Netsurf in the future

Post#17 by Ed_P » 15 Jun 2019, 17:58

Maybe CERN's browser would be a better choice.

https://www.zdnet.com/article/cerns-wor ... -its-1990/
Ed

nanZor
Samurai
Samurai
Posts: 187
Joined: 09 Apr 2019, 03:27
Distribution: Porteus 5.0 RC1 XFCE
Location: Los Angeles

[Solved] Include mini-browser Netsurf in the future

Post#18 by nanZor » 17 Jun 2019, 07:59

Heh, well just tested the latest XFCE4 5.0 RC1 and see that the desktop link to the Porteus faq leads to calling up Lynx in U/Xterm, instead of calling up the browser chooser!

I think this is great. However, I see that as a proof-of-concept using lynx and uxterm. Us old timers are going to gravitate naturally to /usr/doc and poke around anyway with our own tools, but the new user to linux expects *some* sort of browsing if you are going to present html like that.

I'm not complaining! Heck, I might even call up Steve Kirkendall's vi clone, ELVIS which has a built in html browser if you run the latest 2.2x or so. Good times, but that's from "your Dad's distro." :)

I'm half-tempted to re-code the Porteus faq into something classic like the *bsd docs for a graphical browser. Not that I'm any good, but I'd have to dust off my html skills....
That's a UNIX book - cool. -Garth

neko
DEV Team
DEV Team
Posts: 1654
Joined: 09 Feb 2013, 09:55
Distribution: APorteus-FVWM-ja-x86_64.iso
Location: japan

[Solved] Include mini-browser Netsurf in the future

Post#19 by neko » 28 Jun 2019, 07:27

@nanZor
The most recent version of 64Bit netsurf can be gotten with the mknetsurf command.
spm-19.06.26-noarch-2.xzm includes the mknetsurf command.

spm-19.06.26-noarch-2.xzm (2 M)
http://www.mediafire.com/file/6p74gb4b8 ... arch-2.xzm
md5sum: 9cad65531a3b380efff5413ccfd8559f spm-19.06.26-noarch-2.xzm


Thanks.

Kulle
Shogun
Shogun
Posts: 231
Joined: 28 Jan 2017, 10:39
Distribution: v4.0 64bit Xfce
Location: Berlin

[Solved] Include mini-browser Netsurf in the future

Post#20 by Kulle » 28 Jun 2019, 08:59

Hi neko,
I downloaded spm-19.06.26-noarch-2.xzm from the above link.
But the command mknetsurf does not exist.
The mknetsurf command is not included!
Note:
When using appears: Version 19.06.21-1 and not 19.06.26
could that be the error?

neko
DEV Team
DEV Team
Posts: 1654
Joined: 09 Feb 2013, 09:55
Distribution: APorteus-FVWM-ja-x86_64.iso
Location: japan

[Solved] Include mini-browser Netsurf in the future

Post#21 by neko » 28 Jun 2019, 09:58

@Kulle
Thank you for your interest to the tool.
Please operation as followed.

Code: Select all

% ls
spm-19.06.26-noarch-2.xzm
% su
# activate spm-19.06.26-noarch-2.xzm
# which mknetsurf
/usr/local/sbin/mknetsurf
# mknetsurf
# ls
netsurf-3.8.4704-x86_64-1.xzm
spm-19.06.26-noarch-2.xzm
# deactivate spm-19.06.26-noarch-2.xzm
# activate netsurf-3.8.4704-x86_64-1.xzm
3.8.4704 is the most recent version of netsurf at just now.

Thanks.

neko
DEV Team
DEV Team
Posts: 1654
Joined: 09 Feb 2013, 09:55
Distribution: APorteus-FVWM-ja-x86_64.iso
Location: japan

[Solved] Include mini-browser Netsurf in the future

Post#22 by neko » 28 Jun 2019, 11:05

@Kulle
Excuse me !
"mknetsurf" command doesn't run correctly.
Because there is not library "libbfd-2.26.20160125.so".
Please activate following module.


binutils-2.26-x86_64-3.xzm (7 M)
http://www.mediafire.com/file/dr0jd67gb ... 6_64-3.xzm
md5sum: e36392cdbc40f8b9658914846e50dbf9 binutils-2.26-x86_64-3.xzm


mknetsurf convert DEB module with "ar" command.
"ar" command is included Porteus
but Porteus doesn't include "libbfd-2.26.20160125.so" that is used by "ar" command.


Thanks.

bour59
Samurai
Samurai
Posts: 151
Joined: 29 Dec 2010, 08:10
Distribution: porteus v4.0-xfce
Location: France

[Solved] Include mini-browser Netsurf in the future

Post#23 by bour59 » 28 Jun 2019, 12:19

thanks neko
but only the gtk version is build and is ok
The framebuffer version is missing which is useable for init3 users

Kulle
Shogun
Shogun
Posts: 231
Joined: 28 Jan 2017, 10:39
Distribution: v4.0 64bit Xfce
Location: Berlin

[Solved] Include mini-browser Netsurf in the future

Post#24 by Kulle » 28 Jun 2019, 13:02

Hi neko,
It did not work:

Code: Select all

root@porteus:/usr/local/sbin# ./mknetsurf
....
Creating 4.0 filesystem on netsurf-3.8.4704-x86_64-1.xzm, block size 262144.
...
root@porteus:/usr/local/sbin# netsurf-gtk 
netsurf-gtk: error while loading shared libraries: libssl.so.1.1: cannot open shared object file: No such file or directory
Note: binutils-2.32-x86_64-1.xzm is activated (it is in the folder Porteus modules)

bour59
Samurai
Samurai
Posts: 151
Joined: 29 Dec 2010, 08:10
Distribution: porteus v4.0-xfce
Location: France

[Solved] Include mini-browser Netsurf in the future

Post#25 by bour59 » 28 Jun 2019, 13:13

hi Kulle
may be you have to activate the 05-devel.xzm

neko
DEV Team
DEV Team
Posts: 1654
Joined: 09 Feb 2013, 09:55
Distribution: APorteus-FVWM-ja-x86_64.iso
Location: japan

[Solved] Include mini-browser Netsurf in the future

Post#26 by neko » 28 Jun 2019, 14:20

@bour59
"mknetsurf" builds minimum netsurf with netsurf-common and netsurf-gtk.
If you need full set, please modify shell script as follows.

Line 112 of /usr/local/share/mknetsurf/bin/mknetsurf
OLD
for i in `grep "$VERSION" /tmp/mknetsurf$$/index.html|cut -d'"' -f8|egrep -e "netsurf-common_$V|netsurf-gtk_$V"`
NEW
for i in `grep "$VERSION" /tmp/mknetsurf$$/index.html|cut -d'"' -f8`

Note:
The packages of this site is updated as soon as source code is update.
"https://ci.netsurf-browser.org/debian/buster/amd64/"


Thanks.

--------------------------------
@Kulle
The most recent netsurf runs in Porteus v5.0rc1 x86_64.
It doesn't run in Porteus v4.0 x86_64.
Because there is not libssl.so.1.1 in Porteus v4.0 x86_64.

[libssl.so]
=== Porteus v4.0 x86_64 ===

Code: Select all

% lsxzm ISO@/porteus/base/001-core.xzm | grep libssl
/lib64/libssl.so.1
/lib64/libssl.so.1.0.0
/usr/lib64/libssl.so
/usr/lib64/libssl.so.1
/usr/lib64/libssl.so.1.0.0
/usr/lib64/libssl3.so
=== Porteus v5.0rc1 x86_64 ===

Code: Select all

% lsxzm ISO@/porteus/base/001-core.xzm | grep libssl
/lib64/libssl.so.1.1
/usr/lib64/libssl.so
/usr/lib64/libssl.so.1
/usr/lib64/libssl.so.1.1
/usr/lib64/libssl3.so

Thanks.

bour59
Samurai
Samurai
Posts: 151
Joined: 29 Dec 2010, 08:10
Distribution: porteus v4.0-xfce
Location: France

[Solved] Include mini-browser Netsurf in the future

Post#27 by bour59 » 30 Jun 2019, 02:47

@neko ... netsurf-fb
running porteus 5.0rc1
I made the modif in mknetsurf and created the xzm
after resolving (gotten from slackware-current)
-libxcb-icccm.so
-libxcb-image.so
-libxcb-keysyms.so
-libxcb-util.so
-libvncserver.so
when I start netsurf-fb I get :
libcurl.so.4 no version available (required by netsurf-fb) :%)

neko
DEV Team
DEV Team
Posts: 1654
Joined: 09 Feb 2013, 09:55
Distribution: APorteus-FVWM-ja-x86_64.iso
Location: japan

[Solved] Include mini-browser Netsurf in the future

Post#28 by neko » 30 Jun 2019, 06:02

@bour59
I built netsurf-fb package whose dependencies were constructed with archLinux packages.
And I executed it on Porteus 5.0rc1 from terminal.
I got the same message on the terminal.
"netsurf-fb: /usr/lib64/libcurl.so.4: no version information available (required by netsurf-fb)"

Me too, I don't know what the message is.

netsurf-FB.xzm (3.4 M)
http://www.mediafire.com/file/4gf95ot8o ... urf-FB.xzm
md5sum: 8c6c669af11b4834367eb103b053d4ad netsurf-FB.xzm


Thanks.

bour59
Samurai
Samurai
Posts: 151
Joined: 29 Dec 2010, 08:10
Distribution: porteus v4.0-xfce
Location: France

[Solved] Include mini-browser Netsurf in the future

Post#29 by bour59 » 30 Jun 2019, 08:52

@neko
please this an error don't care this following
I've created a tgz from the xzm
installed it on a slackware current, and netsurf-fb runs ok

neko
DEV Team
DEV Team
Posts: 1654
Joined: 09 Feb 2013, 09:55
Distribution: APorteus-FVWM-ja-x86_64.iso
Location: japan

[Solved] Include mini-browser Netsurf in the future

Post#30 by neko » 30 Jun 2019, 11:12

@bour59
"netsurf-fb" will be updated frequently.
"netsurf-fb" and dependency part of netsurf-FB.xzm can be separated.

[How to update netsurf-fb of netsurf-FB.xzm]
1. preparation
(1) spm-19.06.26-noarch-2.xzm
refer to [Solved] Include mini-browser Netsurf in the future (Post by neko #72558)
(2) binutils-2.26-x86_64-3.xzm
refer to [Solved] Include mini-browser Netsurf in the future (Post by neko #72564)
(3) netsurf-FB.xzm
refer to [Solved] Include mini-browser Netsurf in the future (Post by neko #72585)
(4) modify spm-19.06.26-noarch-2.xzm@/usr/local/share/mknetsurf/bin/mknetsurf
refer to [Solved] Include mini-browser Netsurf in the future (Post by neko #72571)

2. get recent "netsurf-fb"

Code: Select all

% ls -1
binutils-2.26-x86_64-3.xzm
netsurf-FB.xzm
spm-19.06.26-noarch-2.xzm
% su
# activate binutils-2.26-x86_64-3.xzm
# activate spm-19.06.26-noarch-2.xzm
# leafpad /usr/local/share/mknetsurf/bin/mknetsurf
# mknetsurf
# ls -1
binutils-2.26-x86_64-3.xzm
netsurf-3.8.NNNN-x86_64-1.xzm
netsurf-FB.xzm
spm-19.06.26-noarch-2.xzm
Note: At my test, netsurf-3.8.NNNN-x86_64-1.xzm was netsurf-3.8.4711-x86_64-1.xzm.

3. separate xzm module to packages.

Code: Select all

# dXZM netsurf-FB.xzm
# sep2pkg netsurf-FB
# dXZM netsurf-3.8.NNNN-x86_64-1.xzm
# sep2pkg netsurf-3.8.NNNN-x86_64-1
# ls -1
binutils-2.26-x86_64-3.xzm
netsurf-3.8.NNNN-x86_64-1.xzm
netsurf-FB.xzm
pkgs.netsurf-3.8.NNNN-x86_64-1
pkgs.netsurf-FB
spm-19.06.26-noarch-2.xzm
4. replace pkg.netsurf-3.8.4710-x86_64-1 with pkgs.netsurf-3.8.NNNN-x86_64-1

Code: Select all

# ls -1 pkgs.netsurf-FB
font
lib4netsurf-3.8.4710-x86_64-1
pkg.netsurf-3.8.4710-x86_64-1
slklib64
xcb-util-0.4.0-x86_64-3
# rm -fr pkgs.netsurf-FB/pkg.netsurf-3.8.4710-x86_64-1
# mv pkgs.netsurf-3.8.NNNN-x86_64-1 pkgs.netsurf-FB/pkg.netsurf-3.8.NNNN-x86_64-1
Note 1: pkgs... ---> pkg...
Note 2: next remove directory will be pkgs.netsurf-FB/pkg.netsurf-3.8.NNNN-x86_64-1.

5. build new netsurf-FB.xzm

Code: Select all

# mv netsurf-FB.xzm old.netsurf-FB.xzm
# pkgs2xzm pkgs.netsurf-FB
# rm -fr pkgs.netsurf-FB netsurf-3.8.NNNN-x86_64-1.xzm
# ls -1
binutils-2.26-x86_64-3.xzm
netsurf-FB.xzm
old.netsurf-FB.xzm
spm-19.06.26-noarch-2.xzm

Thanks.

Post Reply