gimp-2.10.22-x86_64-2 stripped + minimal dependencies for 5.0rc

Post links to your 64bit module repos here. Repo maintainers are responsible for resolving any issues caused by their xzm's.
Post Reply
User avatar
Rava
Contributor
Contributor
Posts: 2949
Joined: 11 Jan 2011, 02:46
Distribution: Porteus 5.0rc2 + 4.0 i586 XFCe
Location: Forests of Germany

gimp-2.10.22-x86_64-2 stripped + minimal dependencies for 5.0rc

Post#1 by Rava » 17 Jan 2021, 17:38

gimp-2.10.22-x86_64-2_stripped+minimal_dependencies_rava.xzm
Size 13.04 MB - 13668352 bytes
md5sum 8082a5340b79f4694cc4bbb7d06b45f2

Since filehorst speaks German, a short HOWTO download and translation:

To get it, first wait 15 seconds "Dein Download wird jetzt vorbereitet." (Your download is being prepared)
Then click "Jetzt zur Download-Seite" (now to the download page)
Then click "Dein Download steht nun bereit. Klicke hier, um ihn zu starten." (Your download is ready. Click here to start downloading it)
_______________________________________

Did only test it on Openbox 5.0rc so far - tests to be yet done are while running the following 5.0rc DEs:
XFCE
KDE
mate
cinnamon

Please report any issues when you use any of the yet untested DEs, but please also report when an above listed DE works out of the box.
Cave: GIMP lists many errors about missing dependencies or files at startup, so far none of these have been of any issue, but recall: So far I only did some minimal testing [details below], so I might miss important dependencies (like I did not test any babl as of yet)
_______________________________________

added (with md5sums)

Code: Select all

82752e1538d25b65618ae965e39329c4  babl-0.1.84-x86_64-1.txz
3e6d399b6caa394f1fc229501a34bb05  gegl-0.4.28-x86_64-2.txz
fe2c9d4fa09abbb906e6ad70a57bcfa9  gexiv2-0.12.1-x86_64-1.txz
b7e5b1eba4ec2f1bd988b96332dba0f4  libmypaint-1.6.1-alt1.x86_64.rpm (via libmypaint-1.6.1-alt1.x86_64.txz conversion)
_______________________________________

removed
various: brushes, icons, beavis.jpg, locale(s)

in detail: removed
/usr/share/gimp/2.0/brushes/Fun/Wilber.gih 8.8M

removed
/usr/share/gimp/2.0/icons :
5M Symbolic-Inverted-High-Contrast
5M Symbolic-High-Contrast

resized:
/usr/share/gimp/2.0/images/gimp-splash.png now 324 KB instead of 3.2 MB

Code: Select all

┌────────────────────── File exists ──────────────────────┐
│ New     : /mnt/loop/usr/share/gi~images/gimp-splash.png │
│                      331788                Jan 29  2019 │
│ Existing: /mnt/sdxy/Porteus_modu~images/gimp-splash.png │
│                     3354880                Oct 29 19:47 │
├─────────────────────────────────────────────────────────┤
│                  Overwrite this file?                   │
│                [ Yes ] [ No ] [ Append ]                │

did minimal testing:

some gegl operations
some filtering

opened and exported as same format:
jpeg
webp
gif (animated)
png (with transparency)

Not yet tested
png (animated) - reason: found none for testing on the spot

●●●●●●●●●●●●●●●●●●●●●●●●●●●●●●●●●●●●●●●

If you use Cinnamon 5.0rc2 or maybe even another rc2 DE and get this error

Code: Select all

guest@porteus:~$ ldd /usr/bin/gimp-2.10|grep "not found"
	libexiv2.so.27 => not found
guest@porteus:~$ 
you also need this:

Code: Select all

3ea38cd68ba12a0c621d1c3877cb07bc  libexiv2-0.27.3-alt1.x86_64.xzm
https://mega.nz/file/W3ZX0abS#3SQ_cXoHn ... 4RKvET3jxw

Thanks to Ed_P for providing libexiv2-0.27.3-alt1.x86_64.xzm . :)

●●●●●●●●●●●●●●●●●●●●●●●●●●●●●●●●●●●●●●●

Cave!
If you need your locale, please tell me so here and I will upload gimp-2.10.22-x86_64-2_locales-only_rava.xzm (md5sum ac7ad289e52ff8f887697387ba59356f) - size 11.18 MB (11722752 bytes)
Last edited by Rava on 20 Jan 2021, 06:29, edited 4 times in total.
Reason: added libexiv2-0.27.3-alt1.x86_64.xzm link & info
Cheers!
Yours Rava

User avatar
Ed_P
Contributor
Contributor
Posts: 6236
Joined: 06 Feb 2013, 22:12
Distribution: Cinnamon 4.0 & 5.0rc3 ISOs
Location: Western NY, USA

gimp-2.10.22-x86_64-2 stripped + minimal dependencies for 5.0rc

Post#2 by Ed_P » 18 Jan 2021, 05:31

Cinnamon 5.0rc2

Code: Select all

guest@porteus:~$ su
Password: 

root@porteus:/home/guest# ./SysSnapshot.sh
~#  uname -a
Linux porteus.example.net 5.4.57-porteus #1 SMP Sun Aug 9 09:03:28 UTC 2020 x86_64 Intel(R) Core(TM) i3-6100U CPU @ 2.30GHz GenuineIntel GNU/Linux

~#  cat /etc/porteus/*
001-core.xzm:20200807
002-xorg.xzm:20200803
002-xtra.xzm:20200803
003-cinnamon.xzm:20200325
initrd.xz:20200108

~#  ls -l /mnt/live/memory/images
000-kernel.xzm : Aug 9 05:22
001-core.xzm : Aug 7 04:54
002-xorg-20200920.xzm : Aug 3 04:28
002-xtra.xzm : Aug 3 02:15
003-cinnamon.xzm : Jul 20 13:02
07-printing-x86_64-2020-09-15.xzm : Sep 15 11:19
09-pscripts-RC2-20201116.xzm : Nov 16 02:10
firefox-60.9.0esr-x86_64-enUS.xzm : Apr 15 2020
fixFirefox50rc2.xzm : Jun 10 2020
flashplayer-plugin-32.0.0.445-x86_64-1.xzm : Oct 23 19:42
gimp-2.10.22-x86_64-2_stripped+minimal_dependencies_rava.xzm : Jan 17 02:05
gtk+2-2.24.32-x86_64-3.xzm : Apr 23 2020
jre-8u271-x86_64-1.xzm : Oct 30 00:50
mychanges.xzm : Jan 10 00:55

ISO: /porteus5.0/rc2ISOModules/Porteus-CINNAMON-v5.0rc2-x86_64-20200920.iso
  
root@porteus:/home/guest# gimp-2.10
gimp-2.10: error while loading shared libraries: libexiv2.so.27: cannot open shared object file: No such file or directory
root@porteus:/home/guest# 
Ed

User avatar
Rava
Contributor
Contributor
Posts: 2949
Joined: 11 Jan 2011, 02:46
Distribution: Porteus 5.0rc2 + 4.0 i586 XFCe
Location: Forests of Germany

gimp-2.10.22-x86_64-2 stripped + minimal dependencies for 5.0rc

Post#3 by Rava » 18 Jan 2021, 14:13

^
do a ldd on the full path gimp binary like so

Code: Select all

ldd /path/to/gimp-2.10 |grep "not found"
not a

Code: Select all

ldd gimp-2.10 |grep "not found"
like so

Code: Select all

guest@porteus:~$ ldd /usr/bin/gimp-2.10|grep "not found"
guest@porteus:~$ 
could be there are more libs missing.
Cheers!
Yours Rava

User avatar
Ed_P
Contributor
Contributor
Posts: 6236
Joined: 06 Feb 2013, 22:12
Distribution: Cinnamon 4.0 & 5.0rc3 ISOs
Location: Western NY, USA

gimp-2.10.22-x86_64-2 stripped + minimal dependencies for 5.0rc

Post#4 by Ed_P » 18 Jan 2021, 15:52

Rava wrote:
18 Jan 2021, 14:13
like so

Code: Select all

guest@porteus:~$ ldd /usr/bin/gimp-2.10|grep "not found"
guest@porteus:~$

Code: Select all

guest@porteus:~$ ldd /usr/bin/gimp-2.10|grep "not found"
	libexiv2.so.27 => not found
guest@porteus:~$ 
:)
Ed

User avatar
Rava
Contributor
Contributor
Posts: 2949
Joined: 11 Jan 2011, 02:46
Distribution: Porteus 5.0rc2 + 4.0 i586 XFCe
Location: Forests of Germany

gimp-2.10.22-x86_64-2 stripped + minimal dependencies for 5.0rc

Post#5 by Rava » 18 Jan 2021, 17:22

found no slack version.
try this:

Code: Select all

wget http://ftp.altlinux.org/pub/distributions/ALTLinux/Sisyphus/x86_64/RPMS.classic/libexiv2-0.27.3-alt1.x86_64.rpm
su -
Password: 
rpm2xzm libexiv2-0.27.3-alt1.x86_64.rpm
activate libexiv2-0.27.3-alt1.x86_64.xzm
and report back.
Cheers!
Yours Rava

User avatar
Ed_P
Contributor
Contributor
Posts: 6236
Joined: 06 Feb 2013, 22:12
Distribution: Cinnamon 4.0 & 5.0rc3 ISOs
Location: Western NY, USA

gimp-2.10.22-x86_64-2 stripped + minimal dependencies for 5.0rc

Post#6 by Ed_P » 18 Jan 2021, 18:02

Code: Select all

guest@porteus:~$ su
Password: 

root@porteus:/home/guest# wget http://ftp.altlinux.org/pub/distributions/ALTLinux/Sisyphus/x86_64/RPMS.classic/libexiv2-0.27.3-alt1.x86_64.rpm
--2021-01-18 12:32:55--  http://ftp.altlinux.org/pub/distributions/ALTLinux/Sisyphus/x86_64/RPMS.classic/libexiv2-0.27.3-alt1.x86_64.rpm
Resolving ftp.altlinux.org (ftp.altlinux.org)... 62.152.55.238
Connecting to ftp.altlinux.org (ftp.altlinux.org)|62.152.55.238|:80... connected.
HTTP request sent, awaiting response... 200 OK
Length: 813578 (795K) [application/x-redhat-package-manager]
Saving to: ‘libexiv2-0.27.3-alt1.x86_64.rpm’

libexiv2-0.27.3-alt 100%[===================>] 794.51K   189KB/s    in 4.2s    

2021-01-18 12:32:59 (189 KB/s) - ‘libexiv2-0.27.3-alt1.x86_64.rpm’ saved [813578/813578]

root@porteus:/home/guest# rpm2xzm libexiv2-0.27.3-alt1.x86_64.rpm

Slackware package maker, version 3.14159265.

Searching for symbolic links:
usr/lib64/libexiv2.so.27	libexiv2.so.0.27.3

Making symbolic link creation script:
( cd usr/lib64 ; rm -rf libexiv2.so.27 )
( cd usr/lib64 ; ln -sf libexiv2.so.0.27.3 libexiv2.so.27 )

It is recommended that you make these lines your new installation script.

Would you like to make this stuff the install script for this package
and remove the symbolic links ([y]es, [n]o)? y


Removing symbolic links:
removed './usr/lib64/libexiv2.so.27'

Creating your new ./install/doinst.sh...

This next step is optional - you can set the directories in your package
to some sane permissions. If any of the directories in your package have
special permissions, then DO NOT reset them here!

Would you like to reset all directory permissions to 755 (drwxr-xr-x) and
directory ownerships to root.root ([y]es, [n]o)? n

Creating Slackware package:  /tmp/rpm2xzm1854/libexiv2-0.27.3-alt1.x86_64.txz

./
install/
install/doinst.sh
usr/
usr/lib64/
usr/lib64/libexiv2.so.0.27.3

Slackware package /tmp/rpm2xzm1854/libexiv2-0.27.3-alt1.x86_64.txz created.

Verifying package libexiv2-0.27.3-alt1.x86_64.txz.
Installing package libexiv2-0.27.3-alt1.x86_64.txz:
PACKAGE DESCRIPTION:
Executing install script for libexiv2-0.27.3-alt1.x86_64.txz.
Package libexiv2-0.27.3-alt1.x86_64.txz installed.
Creating /tmp/rpm2xzm1854/libexiv2-0.27.3-alt1.x86_64.xzm

root@porteus:/home/guest# activate libexiv2-0.27.3-alt1.x86_64.xzm
Updating shared library links:  /sbin/ldconfig

root@porteus:/home/guest# gimp-2.10
GEGL-Message: 12:36:33.232: Module '/usr/lib64/gegl-0.4/exr-load.so' load error: libIlmImf-2_5.so.25: cannot open shared object file: No such file or directory
GEGL-Message: 12:36:33.232: Module '/usr/lib64/gegl-0.4/exr-save.so' load error: libIlmImf-2_5.so.25: cannot open shared object file: No such file or directory
GEGL-Message: 12:36:33.611: Module '/usr/lib64/gegl-0.4/raw-load.so' load error: libraw.so.20: cannot open shared object file: No such file or directory
The connection is closed
gui_dbus_name_lost: connection to the bus cannot be established.
GIMP-Warning: Bad interpreter referenced in interpreter file /usr/lib64/gimp/2.0/interpreters/pygimp.interp: /usr/bin/python2

GIMP-Warning: Bad interpreter referenced in interpreter file /usr/lib64/gimp/2.0/interpreters/pygimp.interp: /usr/bin/python2

GIMP-Warning: Bad interpreter referenced in interpreter file /usr/lib64/gimp/2.0/interpreters/pygimp.interp: /usr/bin/python2

GIMP-Warning: Bad interpreter referenced in interpreter file /usr/lib64/gimp/2.0/interpreters/pygimp.interp: python2

GIMP-Warning: Bad binary format string in interpreter file /usr/lib64/gimp/2.0/interpreters/pygimp.interp

/usr/bin/env: ‘python2’: No such file or directory
gimp-2.10: LibGimpBase-WARNING: gimp-2.10: gimp_wire_read(): error
/usr/bin/env: ‘python2’: No such file or directory
gimp-2.10: LibGimpBase-WARNING: gimp-2.10: gimp_wire_read(): error
/usr/bin/env: ‘python2’: No such file or directory
gimp-2.10: LibGimpBase-WARNING: gimp-2.10: gimp_wire_read(): error
/usr/bin/env: ‘python2’: No such file or directory
gimp-2.10: LibGimpBase-WARNING: gimp-2.10: gimp_wire_read(): error
/usr/bin/env: ‘python2’: No such file or directory
gimp-2.10: LibGimpBase-WARNING: gimp-2.10: gimp_wire_read(): error
/usr/bin/env: ‘python2’: No such file or directory
gimp-2.10: LibGimpBase-WARNING: gimp-2.10: gimp_wire_read(): error
/usr/bin/env: ‘python2’: No such file or directory
gimp-2.10: LibGimpBase-WARNING: gimp-2.10: gimp_wire_read(): error
/usr/bin/env: ‘python2’: No such file or directory
gimp-2.10: LibGimpBase-WARNING: gimp-2.10: gimp_wire_read(): error
Traceback (most recent call last):
  File "/usr/lib64/gimp/2.0/plug-ins/gradients-save-as-css/gradients-save-as-css.py", line 25, in <module>
    from gimpfu import *
  File "/usr/lib64/gimp/2.0/python/gimpfu.py", line 224
    raise error, "procedure name contains illegal characters"
               ^
SyntaxError: invalid syntax
gimp-2.10: LibGimpBase-WARNING: gimp-2.10: gimp_wire_read(): error
/usr/bin/env: ‘python2’: No such file or directory
gimp-2.10: LibGimpBase-WARNING: gimp-2.10: gimp_wire_read(): error
/usr/lib64/gimp/2.0/plug-ins/file-wmf/file-wmf: error while loading shared libraries: libwmf-0.2.so.7: cannot open shared object file: No such file or directory
gimp-2.10: LibGimpBase-WARNING: gimp-2.10: gimp_wire_read(): error
/usr/bin/env: ‘python2’: No such file or directory
gimp-2.10: LibGimpBase-WARNING: gimp-2.10: gimp_wire_read(): error
/usr/lib64/gimp/2.0/plug-ins/file-exr/file-exr: error while loading shared libraries: libIlmImf-2_5.so.25: cannot open shared object file: No such file or directory
gimp-2.10: LibGimpBase-WARNING: gimp-2.10: gimp_wire_read(): error
/usr/bin/env: ‘python2’: No such file or directory
gimp-2.10: LibGimpBase-WARNING: gimp-2.10: gimp_wire_read(): error
Error creating proxy: The connection is closed (g-io-error-quark, 18)
Error creating proxy: The connection is closed (g-io-error-quark, 18)
Error creating proxy: The connection is closed (g-io-error-quark, 18)
Error creating proxy: The connection is closed (g-io-error-quark, 18)
GEGL-Message: 12:38:13.011: Module '/usr/lib64/gegl-0.4/exr-load.so' load error: libIlmImf-2_5.so.25: cannot open shared object file: No such file or directory
GEGL-Message: 12:38:13.011: Module '/usr/lib64/gegl-0.4/exr-save.so' load error: libIlmImf-2_5.so.25: cannot open shared object file: No such file or directory
GEGL-Message: 12:38:13.231: Module '/usr/lib64/gegl-0.4/raw-load.so' load error: libraw.so.20: cannot open shared object file: No such file or directory
GEGL-Message: 12:38:43.557: Module '/usr/lib64/gegl-0.4/exr-load.so' load error: libIlmImf-2_5.so.25: cannot open shared object file: No such file or directory
GEGL-Message: 12:38:43.557: Module '/usr/lib64/gegl-0.4/exr-save.so' load error: libIlmImf-2_5.so.25: cannot open shared object file: No such file or directory
GEGL-Message: 12:38:43.778: Module '/usr/lib64/gegl-0.4/raw-load.so' load error: libraw.so.20: cannot open shared object file: No such file or directory
root@porteus:/home/guest# 
:celebrate3:

And gimp-2.10 now reads jpg files. :Yahoo!:

I recommend starting gimp with

Code: Select all

gimp-2.10 > /dev/null 2>&1 &
:happy62:

I did not try editing any files. I've never used gimp before.
Ed

User avatar
Rava
Contributor
Contributor
Posts: 2949
Joined: 11 Jan 2011, 02:46
Distribution: Porteus 5.0rc2 + 4.0 i586 XFCe
Location: Forests of Germany

gimp-2.10.22-x86_64-2 stripped + minimal dependencies for 5.0rc

Post#7 by Rava » 18 Jan 2021, 19:56

I recommend starting gimp within the GUI.

And gimp is one of the most complex free software out there - look at the mere size of the locale module:

Code: Select all

guest@porteus:/Gimp$ l gimp-2.10.22-x86_64-2_locales-only_rava.xzm
-rwxrwxrwx 1 guest 11722752 2021-01-17 17:31 gimp-2.10.22-x86_64-2_locales-only_rava.xzm
guest@porteus:/Gimp$ 1024calc 11722752
11.1797 MB
11.18 MB
P.S.
You only have 1024calc if you code it yourself.

P.P.S.
Why not upload your libexiv2-0.27.3-alt1.x86_64.xzm - I even edit my initial post so that others find it right away.


P.P.P.S.
Ding Ding Ding Ding Ding Ding Ding Ding Ding just rang the bell for the nightly open prison. :crazy:
Last edited by Rava on 18 Jan 2021, 20:07, edited 1 time in total.
Reason: added the 9 p.m. clocktower bell anouncing the nightly open prison
Cheers!
Yours Rava

User avatar
Ed_P
Contributor
Contributor
Posts: 6236
Joined: 06 Feb 2013, 22:12
Distribution: Cinnamon 4.0 & 5.0rc3 ISOs
Location: Western NY, USA

gimp-2.10.22-x86_64-2 stripped + minimal dependencies for 5.0rc

Post#8 by Ed_P » 18 Jan 2021, 22:21

Rava wrote:
18 Jan 2021, 19:56
Ding Ding Ding just rang the bell for the nightly open prison. :crazy:
:%) :unknown:

A couple of problems with uploading a file. 1. I don't speak German. 2. I don't know whether to upload a libexiv2 file or an updated gimp file. Then there is the naming problem. 3.a. 0909-eds-libexiv2-fix-4-ravas-gimp-2.10.22.xzm or 3.b. 0999-gimp-2.10.22-x86_64-2_eds-stripped&required_dependencies-4-rava.xzm? :unknown:

Another option could be to email you the module and you post it.

I don't understand how your gimp module works for you but not for me. :%)
Ed

User avatar
Rava
Contributor
Contributor
Posts: 2949
Joined: 11 Jan 2011, 02:46
Distribution: Porteus 5.0rc2 + 4.0 i586 XFCe
Location: Forests of Germany

gimp-2.10.22-x86_64-2 stripped + minimal dependencies for 5.0rc

Post#9 by Rava » 18 Jan 2021, 22:34

There are other file hosters than filehorst.

e.g. https://www.mediafire.com <- you sure used that before. And it speaks English. Or https://mega.nz . Also speaks English.

And do not bother with naming, keep it as just libexiv2-0.27.3-alt1.x86_64.xzm - or even libexiv2-0.27.3-alt1.x86_64_edp.xzm

If a user wants to rename it e.g. into gimp-2.10.22-x86_64-2_dependency_libexiv2-0.27.3-alt1.x86_64.xzm he can do so himself.
Cheers!
Yours Rava

User avatar
ncmprhnsbl
DEV Team
DEV Team
Posts: 3054
Joined: 20 Mar 2012, 03:42
Distribution: 5.0-current-64bit
Location: australia
Contact:

gimp-2.10.22-x86_64-2 stripped + minimal dependencies for 5.0rc

Post#10 by ncmprhnsbl » 18 Jan 2021, 23:28

Rava wrote:
18 Jan 2021, 17:22
found no slack version.
the slackware package is named "exiv2" (which is present in 003-xorg)
getpkg exiv2
the version present in rc2 is older than the version now present in slackware current, which is what this version of gimp is built against.
i've recently become aware of this repo: https://slackware.uk/cumulative/slackwa ... ackware64/ which is: a cumulative collection of packages of current.
rc2 was released in august of 2020, so the best option for gimp for rc2 would be
https://slackware.uk/cumulative/slackwa ... 6_64-2.txz dated 2020-08-01
with similarly dated deps. (and not needing a special exiv2)
Forum Rules : https://forum.porteus.org/viewtopic.php?f=35&t=44

User avatar
Rava
Contributor
Contributor
Posts: 2949
Joined: 11 Jan 2011, 02:46
Distribution: Porteus 5.0rc2 + 4.0 i586 XFCe
Location: Forests of Germany

gimp-2.10.22-x86_64-2 stripped + minimal dependencies for 5.0rc

Post#11 by Rava » 19 Jan 2021, 04:15

ncmprhnsbl wrote:
18 Jan 2021, 23:28
the best option for gimp for rc2 would be
https://slackware.uk/cumulative/slackwa ... 6_64-2.txz dated 2020-08-01
with similarly dated deps. (and not needing a special exiv2)
but that's gimp-2.10.20-x86_64-2.txz while my version is based on gimp-2.10.22-x86_64-2.txz - md5sum 3c90f3499e78ac590c67b042790f3cae and when wget's date is correct from 2020-10-29 19:48…
You suggest building a module and creating a "gimp-2.10.20-x86_64-2 stripped + minimal dependencies for 5.0rc" thread using https://slackware.uk/cumulative/slackwa ... 6_64-2.txz and also
Rava wrote:
17 Jan 2021, 17:38
added (with md5sums)

Code: Select all

82752e1538d25b65618ae965e39329c4  babl-0.1.84-x86_64-1.txz
3e6d399b6caa394f1fc229501a34bb05  gegl-0.4.28-x86_64-2.txz
fe2c9d4fa09abbb906e6ad70a57bcfa9  gexiv2-0.12.1-x86_64-1.txz
b7e5b1eba4ec2f1bd988b96332dba0f4  libmypaint-1.6.1-alt1.x86_64.rpm (via libmypaint-1.6.1-alt1.x86_64.txz conversion)
Cheers!
Yours Rava

User avatar
Ed_P
Contributor
Contributor
Posts: 6236
Joined: 06 Feb 2013, 22:12
Distribution: Cinnamon 4.0 & 5.0rc3 ISOs
Location: Western NY, USA

gimp-2.10.22-x86_64-2 stripped + minimal dependencies for 5.0rc

Post#12 by Ed_P » 19 Jan 2021, 05:34

Rava wrote:
18 Jan 2021, 22:34
There are other file hosters than filehorst.

e.g. https://www.mediafire.com <- you sure used that before. And it speaks English. Or https://mega.nz . Also speaks English.
www.mediafire.com > tried 6x > Failed (network error) ! Upload cancelled :%)
Reset password, signed on with Facebook, same results. :wall: Check your email.

Added in 4 minutes 57 seconds:
:x Files can't be attached to emails or pms sent to members. :wall:

I'll fight with this tomorrow. :fool:

Added in 12 hours 11 minutes 23 seconds:
Signed onto my mediafire account, could see my old files, tried to upload the xzm file, same error. Used P7zip to zip the xzm file to a 7z file, tried to upload it, same error. Updated Firefox, retried, same error. I tried a non-porteus zip file, same error. I give up. :( You'll have to create the module yourself Rava. Sorry. :sorry:

Added in 4 hours 37 minutes 56 seconds:
The file's download link: https://mega.nz/file/W3ZX0abS#3SQ_cXoHn ... 4RKvET3jxw

Code: Select all

guest@porteus:/mnt/sda6/porteus5.0/Optional$ md5sum libexiv2-0.27.3-alt1.x86_64.xzm
3ea38cd68ba12a0c621d1c3877cb07bc  libexiv2-0.27.3-alt1.x86_64.xzm
:showoff:
Ed

User avatar
Rava
Contributor
Contributor
Posts: 2949
Joined: 11 Jan 2011, 02:46
Distribution: Porteus 5.0rc2 + 4.0 i586 XFCe
Location: Forests of Germany

gimp-2.10.22-x86_64-2 stripped + minimal dependencies for 5.0rc

Post#13 by Rava » 20 Jan 2021, 06:22

confirmed:

Code: Select all

3ea38cd68ba12a0c621d1c3877cb07bc  libexiv2-0.27.3-alt1.x86_64.xzm
Looks like mediafire hates you and https://mega.nz is your friend. :teehee:
Cheers!
Yours Rava

User avatar
Ed_P
Contributor
Contributor
Posts: 6236
Joined: 06 Feb 2013, 22:12
Distribution: Cinnamon 4.0 & 5.0rc3 ISOs
Location: Western NY, USA

gimp-2.10.22-x86_64-2 stripped + minimal dependencies for 5.0rc

Post#14 by Ed_P » 20 Jan 2021, 20:47

Rava wrote:
20 Jan 2021, 06:22
Looks like mediafire hates you
The feeling is mutual. :x
Ed

User avatar
Rava
Contributor
Contributor
Posts: 2949
Joined: 11 Jan 2011, 02:46
Distribution: Porteus 5.0rc2 + 4.0 i586 XFCe
Location: Forests of Germany

gimp-2.10.22-x86_64-2 stripped + minimal dependencies for 5.0rc

Post#15 by Rava » 21 Jan 2021, 23:43

Ed_P wrote:
20 Jan 2021, 20:47
The feeling is mutual. :x
looked a bit into mediafire's cookies settings, a road to :bad:
Vendor preferences
Confirm our vendors

Vendors can use your data to provide services. Declining a vendor can stop them from using the data you shared.
" can " stop them - not will stop them =@

looked into vendors and found this gem
AAX LLC
Cookie duration: 2191 days. Uses non-cookie storage
View details | Privacy policy launch
Consent
Legitimate interest
Cookie duration: 2191 days WTF that is 6 years!

also, by which rules do have vendors "legitimate interest" and rights to my data? :bad:
Cheers!
Yours Rava

Post Reply