Qt 5.9.5 for Porteus 4.0

Post links to your 64bit module repos here. Repo maintainers are responsible for resolving any issues caused by their xzm's.
Post Reply
jssouza
DEV Team
DEV Team
Posts: 1165
Joined: 09 Jul 2015, 14:17
Distribution: Porteus x86 arm

Qt 5.9.5 for Porteus 4.0

Post#1 by jssouza » 18 May 2018, 04:41

Built from the official sources at http://download.qt.io/official_releases ... ubmodules/

qt5-base-5.9.5-x86_64-jss.xzm
Contans packages needed by qt, qtbase, qtx11extras, qtsvg and qtserialport- for developing minimal Qt widgets based application
http://www.mediafire.com/file/n6m2vta9w ... 64-jss.xzm
md5sum: 2ad091e0d184ba388767aab5a2a81fbc

qt5-quick-5.9.5-x86_64-jss.xzm
Contans qtdeclarative, qtquickcontrols, qtquickcontrols2 and qtgraphicaleffects - for developing QML/Qt Quick applications
http://www.mediafire.com/file/n7zsigd2a ... 64-jss.xzm
md5sum: 25ab9be3723ff4ccafc2dee6b641f6b2

qt5-tools-5.9.5-x86_64-jss.xzm
http://www.mediafire.com/file/q49a8al19 ... 64-jss.xzm
md5sum: 593f4824b27b1dcdd743bffbbf6fbc94

qt5-script-5.9.5-x86_64-jss.xzm
http://www.mediafire.com/file/ugjyfxomr ... 64-jss.xzm
md5sum: 9c8392d2569b62a7281b75be9936e94e

qt5-translations-5.9.5-x86_64-jss.xzm
http://www.mediafire.com/file/cydxw4lei ... 64-jss.xzm
md5sum: 1fc78e5f90d9bddf1756072f881db52d

rych
Samurai
Samurai
Posts: 168
Joined: 04 Jan 2014, 04:27
Distribution: Porteus 4.0 64 LXDE
Location: NZ

Qt 5.9.5 for Porteus 4.0

Post#2 by rych » 20 May 2018, 03:39

Thank you so much for these. It solved the problem that I had run into having upgraded to Porteus 4.0: my Qt apps (lyx, texstudio, qpdfview) that used to work on Porteus 3.2.2 using qt5-5.9.1-x86_64-1jss.xzm complained about missing libraries. It was apparently the Qt itself that was built against older versioned libicu* system libraries. Your Qt module(s) agree better with Porteus 4.0 and my apps work, without recompiling etc. Thanks.

jssouza
DEV Team
DEV Team
Posts: 1165
Joined: 09 Jul 2015, 14:17
Distribution: Porteus x86 arm

Qt 5.9.5 for Porteus 4.0

Post#3 by jssouza » 20 May 2018, 05:33

Cool :Yahoo!:

Yes, you are right. Qt modules need to be rebuilt every time Slackware bumps icu4c.

fulalas
DEV Team
DEV Team
Posts: 1551
Joined: 26 Oct 2016, 15:34
Distribution: Porteus
Location: Brazil

Qt 5.9.5 for Porteus 4.0

Post#4 by fulalas » 20 May 2018, 21:52

Cool! :punk:

BTW, have you heard about this Qt Lite? It seems interesting, don't you think?

rych
Samurai
Samurai
Posts: 168
Joined: 04 Jan 2014, 04:27
Distribution: Porteus 4.0 64 LXDE
Location: NZ

Qt 5.9.5 for Porteus 4.0

Post#5 by rych » 21 May 2018, 06:38

@fulalas, if there were indeed a user-friendly tool to prebuild a subset of Qt, I'd try to use it. For now, it's great to have your help. By the way, why not Qt 5.10? I'd like to try and convert one of https://opensuse.pkgs.org/tumbleweed/op ... 4.rpm.html or https://archlinux.pkgs.org/rolling/arch ... ar.xz.html both of which require Qt 5.10.

jssouza
DEV Team
DEV Team
Posts: 1165
Joined: 09 Jul 2015, 14:17
Distribution: Porteus x86 arm

Qt 5.9.5 for Porteus 4.0

Post#6 by jssouza » 22 May 2018, 13:28

fulalas wrote:
20 May 2018, 21:52
BTW, have you heard about this Qt Lite? It seems interesting, don't you think?
No, but I agree, it sounds quite interesting. I guess it is useful for embedded systems that that run one single main application, so that all other parts of qt that are not needed can be stripped off. Hard to do that for a DE (lxqt, KDE) since we would not know what modules users would build on top of the DE.
But would be interesting on a non-qt based DE that needs a module that has a a qt dependency (like rych needing lyx on LXDE). In that case, we can make a qtbase that is Qt Lite and needs only what lyx needs, I guess.
Unfortunately the Lite Tool is available only for enterprise users. Lets see, if we can build a generic lite variant of qtbase and see what applications can be built on top of that.

apollo
Black ninja
Black ninja
Posts: 75
Joined: 28 Oct 2017, 13:40
Distribution: 4.0 XFCE, Manjaro
Location: .bay.de

Qt 5.9.5 for Porteus 4.0

Post#7 by apollo » 23 May 2018, 19:56

Nice small module to get the base Qt deps to XFCE.
Thank you very much. :hi:

User avatar
Ed_P
Contributor
Contributor
Posts: 5539
Joined: 06 Feb 2013, 22:12
Distribution: 4.0 Cinnamon 64-bit ISO
Location: Western NY, USA

Qt 5.9.5 for Porteus 4.0

Post#8 by Ed_P » 23 May 2018, 20:15

jssouza wrote:
22 May 2018, 13:28
Unfortunately the Lite Tool is available only for enterprise users.
The download page shows an Open Source version.
Ed

fulalas
DEV Team
DEV Team
Posts: 1551
Joined: 26 Oct 2016, 15:34
Distribution: Porteus
Location: Brazil

Qt 5.9.5 for Porteus 4.0

Post#9 by fulalas » 23 May 2018, 22:04

@Ed_P, he was not referring to Qt, but Qt Lite.

To be honest, it wasn't clear to me that Qt Lite requires Qt Configuration Tool UI (which is indeed a commercial only tool). And one guy on the comments said that you can do the same using:

Code: Select all

configure --list-features

User avatar
Ed_P
Contributor
Contributor
Posts: 5539
Joined: 06 Feb 2013, 22:12
Distribution: 4.0 Cinnamon 64-bit ISO
Location: Western NY, USA

Qt 5.9.5 for Porteus 4.0

Post#10 by Ed_P » 23 May 2018, 22:18

fulalas wrote:
23 May 2018, 22:04
@Ed_P, he was not referring to Qt, but Qt Lite.
True but the Qt Lite link says Qt Lite is in Qt 5.9 and in Qt 5.8 not separate from them.
Ed

User avatar
francois
Contributor
Contributor
Posts: 5795
Joined: 28 Dec 2010, 14:25
Distribution: xfce plank porteus nemesis
Location: Le printemps, le printemps, le printemps... ... l'hiver s'essoufle.

Qt 5.9.5 for Porteus 4.0

Post#11 by francois » 28 Mar 2020, 09:22

Useful modules!
Thanks.
Prendre son temps, profiter de celui qui passe.

rych
Samurai
Samurai
Posts: 168
Joined: 04 Jan 2014, 04:27
Distribution: Porteus 4.0 64 LXDE
Location: NZ

Qt 5.9.5 for Porteus 4.0

Post#12 by rych » 12 Jul 2020, 08:01

dear jssouza, hope you're still around and thank you again for the modules. I'm now trying to use a recoll package (https://altlinux.pkgs.org/sisyphus/clas ... 4.rpm.html) and it requires Qt5WebKitWidgets (at least, maybe some others). None of your modules contain those, right?

fulalas
DEV Team
DEV Team
Posts: 1551
Joined: 26 Oct 2016, 15:34
Distribution: Porteus
Location: Brazil

Qt 5.9.5 for Porteus 4.0

Post#13 by fulalas » 22 Jul 2020, 04:40

@rych, you can find new and full versions of Qt here, under 'Slackware current': https://pkgs.org/download/qt5

User avatar
Ed_P
Contributor
Contributor
Posts: 5539
Joined: 06 Feb 2013, 22:12
Distribution: 4.0 Cinnamon 64-bit ISO
Location: Western NY, USA

Qt 5.9.5 for Porteus 4.0

Post#14 by Ed_P » 22 Jul 2020, 16:42

There's a version available in USM.

Code: Select all

guest@porteus:~$ su
Password: 
root@porteus:/home/guest# usm -g recoll

 The following items were found.
 Choose an number to confirm. 
 ctrl+c to quit

1) recoll-1.22.3-x86_64-1_slonly.txz
#? 1

Processing:   recoll-1.22.3-x86_64-1_slonly.txz 
Ignored libraries: 

Libraries required:  14
Libraries found in system: 12
Libraries to resolve: 2

Processing library: librecoll-1.22.3.so
Processing library: libxapian.so.22


Processing:   xapian-core-1.2.22-x86_64-1.txz 
Ignored libraries: 

Libraries required:  6
Libraries found in system: 5
Libraries to resolve: 1

Processing library: libxapian.so.22


 The following packages are required. 
recoll-1.22.3-x86_64-1_slonly.txz [1640K] [not installed]
xapian-core-1.2.22-x86_64-1.txz [2432K] [not installed]

Total size: 4 MB

 Multiple packages were detected.
 Would you like to merge the packages into one module? [y/n]

Ed

Post Reply