LibreOffice : Locale languages settings

Post tutorials, HOWTO's and other useful resources here.
Post Reply
Posts: 138
Joined: 12 Jun 2021, 21:59
Distribution: Xfce 4.12 - 5.rc3 - x86_64
Location: France

LibreOffice : Locale languages settings

Post#1 by Rapha_ » 07 Dec 2021, 04:46

Thanks to Jack who provided us with the latest version of LibreOffice (libreoffice 7.2.2 x86_64 1alien / Current) :
Sujet : Libreoffice-7.2.2 and Boost-1.77.0

I will show you how to set up your local language on LibreOffice :

1) That is to say to have the translation of the menus
2) and the spelling correction of your own language

1) First, you need to download the translated version of the software (libreoffice language pack) : :
Select : X current - X x86_64
Search(*): libreoffice-l10n

libreoffice-l10n-YOUR_LANGUAGE-7.2.3-x86_64-1alien.txz (4.4 Mib~) => txz2xzm > module

Activate LibreOffice modules + language package > then load libreOffice Writer

Go to Menus > Tools > Option > Language settings > Language

-----> Select your language for :

Language of : User interface
Formats : Local settings & Default currency
Default languages for Documents

--> apply
For the updated language settings to take effect, LibreOffice must be restarted
---> Restart now

The new menus appears ! :) (but don't open or write any document yet !)
---> Quit to save settings

To keep the saved settings, copy the file registrymodifications.xcu to rootcopy :

(copy all the modules concerning LibreOffice in the optional folder)

2) 2nd step and the spelling correction...

To get a spelling correction you need to download 2 packages:

- your local dictionary (2 MB~)
- the spell checker library Hunspell* (300 KB~)
(* in any case it is this library which is asked in the readme.txt of my dictionary ... so check the documentation of your dictionary) :
Traduction :
This dictionary can only work with software that uses the Hunspell checker: 3.2+..."

Slakfinder (Package Finder) :

- libreoffice-dict-YOUR_LANGUAGE-7.2.3-x86_64-1alien / x86_64 / current => txz2xzm module => activate
- hunspell-1.7.0-x86_64-1 / x86_64 / current => txz2xzm module => activate

----> Once these 2 modules are activated, Reload libreOffice Writer

Go to Menus > Tools > Option > Language settings > Writing Aids > Available Language modules > spell checker Hunspell activated ! :crazy:
You just have to use the right mouse button to correct the wrong words ! :celebrate3:

()Juste for information to load with terminal it could help :
libreoffice -help
libreoffice --writer

Post Reply