UEFI prepared USB is not recognized

Technical issues/questions of an intermediate or advanced nature.
Post Reply
Posts: 168
Joined: 04 Jan 2014, 04:27
Distribution: Porteus 4.0 64 LXDE
Location: NZ

UEFI prepared USB is not recognized

Post#1 by rych » 29 Nov 2019, 07:25

1. I followed https://youtu.be/Q_AXMoaRmdQ to partition and format my USB as follows:
root@porteus:~# gdisk /dev/sdc
GPT fdisk (gdisk) version 1.0.3

Partition table scan:
MBR: protective
BSD: not present
APM: not present
GPT: present

Found valid GPT with protective MBR; using GPT.

Command (? for help): p
Disk /dev/sdc: 30720000 sectors, 14.6 GiB
Model: DataTraveler 3.0
Sector size (logical/physical): 512/512 bytes
Disk identifier (GUID): CDBDEECB-74E2-4107-88E1-6288921A54D4
Partition table holds up to 128 entries
Main partition table begins at sector 2 and ends at sector 33
First usable sector is 34, last usable sector is 30719966
Partitions will be aligned on 2048-sector boundaries
Total free space is 2014 sectors (1007.0 KiB)

Number Start (sector) End (sector) Size Code Name
1 2048 206847 100.0 MiB EF00 EFI System
2 206848 14886911 7.0 GiB 0700 Microsoft basic data
3 14886912 30719966 7.5 GiB 8300 Linux filesystem

root@porteus:~# blkid
/dev/sdc1: SEC_TYPE="msdos" UUID="E8F5-3808" TYPE="vfat" PARTLABEL="EFI System" PARTUUID="a9368683-6b0f-4079-9276-e8b445bf47c3"
/dev/sdc2: LABEL="Work7G" UUID="577696D3778F1D2F" TYPE="ntfs" PTTYPE="dos" PARTLABEL="Microsoft basic data" PARTUUID="dcde9a51-abf6-4930-9127-060661bd010a"
/dev/sdc3: LABEL="Porteus5" UUID="30640965-6eb4-4f8b-8e5a-b1dca12f6ed9" TYPE="ext4" PARTLABEL="Linux filesystem" PARTUUID="fcd6095c-9f13-4d5f-8582-896e0151990f"
2. Then I copied from the Porteus-OPENBOX-v5.0rc1-x86_64.iso:

boot and EFI folders to \mnt\sdc1

porteus folder to \mnt\sdc3

3. Added the from= cheatcode to this line in the /mnt/sdc1/boot/syslinux/porteus.cfg:

Code: Select all

APPEND changes=/porteus from=UUID:30640965-6eb4-4f8b-8e5a-b1dca12f6ed9
4. In the folder /mnt/sdc1/boot I ran ./Porteus-installer-for-Linux.com

Unplugged my legacy USB, rebooted, and alas, the new USB is not listed in the UEFI boot submenu. I use my normal porteus USB as a legacy BOOT USB. Windows UEFI is an option, but not my new USB. See my BIOS snapshots
at https://imgur.com/a/ZdArf8H which were made when I already disabled legacy USB boot. (Trying to use the UEFI USB as a legacy one didn't work of course, said no bootable OS found or something.)

In the 1st photo, the Boot Sequence (same list I see on the black POST screen when I press F12) are what my system recognizes as UEFI canditates: host Windows, a couple of NIC, and then I really hoped to see my new USB. Any comments please?

UPDATE: plugged it into another UEFI computer -- not recognised, not in the list of bootable devices
Last edited by rych on 30 Nov 2019, 00:24, edited 1 time in total.

User avatar
Posts: 5539
Joined: 06 Feb 2013, 22:12
Distribution: 4.0 Cinnamon 64-bit ISO
Location: Western NY, USA

UEFI prepared USB is not recognized

Post#2 by Ed_P » 29 Nov 2019, 18:31

Did you read the USB_INSTALLATION.txt file in the Porteus ISO's root?
Ensure the first partition is of type FAT32.
a) Copy the EFI, boot and porteus folders onto the FAT32 partition.

From any Linux Distribution other than Porteus:
a) copy the contents of the ISO image to your drive
b) navigate to the /boot folder and launch the installer
'bash Porteus-installer-for-Linux.com'
c) verify you are installing to the correct drive and press 'Enter' to
complete the installation

From Porteus itself (booted from CD):
a) launch 'Porteus Installer' from the desktop menu,
under the 'System' heading (if you are
prompted for the root password, it is toor)
b) plug in your usb drive or select a partition
on a hard drive
c) follow the on-screen instructions
If you run into trouble please refer to the more
detailed installation guide which can be found at
They worked for me. :)

Posts: 168
Joined: 04 Jan 2014, 04:27
Distribution: Porteus 4.0 64 LXDE
Location: NZ

UEFI prepared USB is not recognized

Post#3 by rych » 30 Nov 2019, 05:16

Yes, Ed_P, I've read and done those I believe. Except I didn't use the Porteus Installer GUI. I used command line tools. If someone could find an error in my procedure I'd be most grateful.

I can now add another UPDATE:

On the first machine, in the same BIOS GUI as in snapshots above, I can actually add an entry into UEFI boot list submenu. It has a primitive file picker and I can choose the /EFI/boot/bootx64.efi file for it, which is obviously from the USB! So, at least the BIOS sees the EFI partition. The new entry, when selected on boot, does nothing however, and booting continues into the Windows.

Snapshots: https://imgur.com/a/cYseEjH


Post Reply