Page 1 of 1

[Solved] HP printer not printing

Posted: 10 Apr 2024, 19:19
by Ed_P
My HP printer which I've had for a while and use to work with Windows and Porteus has stopped working in Porteus.

I was having problema printing on 2 sides so in Windows 11 I installed some HP apps to resolve the problem and they worked, in Windows, but now Porteus doesn't print to it, 1 sided or 2 sided. My partner's Windows 11 notebook has had no problem printing 2 sided to the same printer.

Code: Select all

~#  ls -l /mnt/live/memory/images
000-kernel.xzm : Mar 5 12:26
001-core.xzm : Mar 1 06:24
002-xorg.xzm : Mar 1 06:29
002-xtra.xzm : Mar 1 06:34
003-cinnamon.xzm : Dec 29 00:05
07-printing-x86_64-2023-02-04.xzm : Feb 4 2023
Dell6.4.10-wifi.xzm : Aug 18 2023
Dellautonet.xzm : Dec 19 16:00
Dellsound.xzm : May 14 2022
firefox-122.0-x86_64-en-US.xzm : Jan 27 23:51
mychanges.xzm : Mar 30 12:00
wmctrl-1.07-x86_64-2salix15.0.xzm : Feb 6 11:54

HP printer not printing

Posted: 11 Apr 2024, 10:36
by burdi01
Try driverless printing, which I implemented for Slackware and PartedMagic:

Code: Select all

(c) DLCB 17/3-2024

When avahi is active
   CUPS can "see" the driverless printer
   Add that printer via localhost:631 and select the "IPP Everywhere" model
   See below for details.

   One could start avahi via "/etc/rc.d/rc.avahi start"
   goto above

   To find the printer's IPaddress run as root:
   >>> nmap --script=broadcast-dns-service-discovery |& tee log.log
   Edit/view the log.log file, search for "ipps" and see the "Address" entry some 18 lines below

   To create the spool entry run as root:
   >>> lpadmin -p "MyPrinter" -v ipps://XXX.XXX.XXX.XXX/ipp/print -E -m everywhere


Start CUPS: /etc/rc.d/rc.cups start
In your browser connect to "localhost:631"
Administration > Add Printer
Discovered Network Printers > driverless
Model > IPP Everywhere
Administration > Set As Server Default
Maintenance > Print Test Page

HP printer not printing

Posted: 11 Apr 2024, 18:08
by Ed_P
Thank you burdi01. Unfortunately I don't have avahi.

Code: Select all

guest@porteus:/etc/rc.d$ /etc/rc.d/rc.avahi start
bash: /etc/rc.d/rc.avahi: No such file or directory
guest@porteus:/etc/rc.d$ su
root@porteus:/etc/rc.d# /etc/rc.d/rc.avahi start
bash: /etc/rc.d/rc.avahi: No such file or directory
In playing around with the Manage Printing settings today, I got my printer to work by searching for printers and basically re-adding it. :o

The printer on top doesn't work but the new bottom one does. Same IP address,, same settings. :unknown: The only difference I see is - got replaced with _. :crazy: Now I need to figure out how to delete the top one. :D


Added in 3 hours 17 minutes 34 seconds:
[Solved] HP printer not printing
Ed_P wrote:
11 Apr 2024, 18:08
Now I need to figure out how to delete the top one.
Clicked on the top one, selected Delete Printer. :good:

[Solved] HP printer not printing

Posted: 12 Apr 2024, 10:02
by burdi01
Avahi was added to Slackware Current quite recently -- and indeed the 1rst method now works.
Before this addition I used the 3rd method successfully.
Note that driverless printing is the way printing is heading for.