Autostart

Willkommen!
MichaelD
White ninja
White ninja
Posts: 7
Joined: 14 Aug 2023, 18:03
Distribution: Porteus-LXDE-v2.1-x86_64

Autostart

Post#1 by MichaelD » 14 Aug 2023, 18:19

Hallo, ich bin neu hier und habe im Grunde keine Ahnung von Linux.
Ich hatte ein kleines schnelles Betriebssystem gesucht, das auf alten Notebooks und kleinen lahmen Rechnern läuft.
Ich möchte ausschließlich per RDP auf meinen Windows-Rechner zugreifen.
Fündig wurde ich bei Porteus. Ich habe Porteus-LXDE-v2.1-x86_64 erfolgreich installiert.
Per rdesktop kann ich auf den Windows-Rechner zugreifen.
Ich habe sowohl die im Settings-Center angesiedelte Script-Funktion, die mir die Datei S-startup-script.sh erstellt hat als auch eine *.desktop - Datei erstellt.
Beide Dateien starten bei Doppelklick rdesktop mit den eingegebenen Parametern.
Nun suche ich danach, wie ich es hinbekommenkann, dass rdesktop mit den Parametern gleich beim Hochfahren startet, also einen Autostart.
Ich hoffe, es kann mir jemand den Schubs in die richtige Richtung geben.
Vielen Dank

donald
Full of knowledge
Full of knowledge
Posts: 2077
Joined: 17 Jun 2013, 13:17
Distribution: Porteus 3.2.2 XFCE 32bit
Location: Germany

Autostart

Post#2 by donald » 15 Aug 2023, 20:58

Hi Micha
Hast du es schon mit einem .desktop file in /home/guest/.config/autostart/
probiert?

MichaelD
White ninja
White ninja
Posts: 7
Joined: 14 Aug 2023, 18:03
Distribution: Porteus-LXDE-v2.1-x86_64

Autostart

Post#3 by MichaelD » 16 Aug 2023, 12:47

Ja, habe ich schon, es funktioniert leider nicht.

Mein .desktop File sieht so aus:

[DESKTOP ENTRY]
Type=Application
Name=RDP-Server.desktop
Comment= RDP Server
Exec=rdesktop Server -g 1440x850 -u ... -p ...

donald
Full of knowledge
Full of knowledge
Posts: 2077
Joined: 17 Jun 2013, 13:17
Distribution: Porteus 3.2.2 XFCE 32bit
Location: Germany

Autostart

Post#4 by donald » 16 Aug 2023, 17:36

Hi
Funktioniert deine (exec=) syntax denn im Terminal?
...vielleicht fehlen Anführungszeichen ".." oder der Pfad
zur Binary?

Hat es einen Grund das du eine (ur)alte Version (2.1) benutzt?

MichaelD
White ninja
White ninja
Posts: 7
Joined: 14 Aug 2023, 18:03
Distribution: Porteus-LXDE-v2.1-x86_64

Autostart

Post#5 by MichaelD » 17 Aug 2023, 08:45

Die (Exec=) Syntax funktioniert im Terminal einwandfrei. Auch bei Doppelclick auf die Datei funktioniert es bestens.
Kann es vielleicht etwas damit zu tun haben, dass ich das ganze zum testen in VirtualBox laufen lasse?

2.1 habe ich, da es wirklich sehr klein und auch sehr schnell ist.
Habe auch mit 4.0 und 5.0 versucht. Brauchen länger zum hoch- und runterfahren und den Autostart habe ich da auch nicht hinbekommen.

MichaelD
White ninja
White ninja
Posts: 7
Joined: 14 Aug 2023, 18:03
Distribution: Porteus-LXDE-v2.1-x86_64

Autostart

Post#6 by MichaelD » 17 Aug 2023, 16:25

Habe es nun auch auf einem alten Laptop installiert, Autostart haut auch da nicht hin.

donald
Full of knowledge
Full of knowledge
Posts: 2077
Joined: 17 Jun 2013, 13:17
Distribution: Porteus 3.2.2 XFCE 32bit
Location: Germany

Autostart

Post#7 by donald » 17 Aug 2023, 18:45

Ist deine RDP-Server.desktop [in /.config/autostart) auch in lxde-menü > preferences > Desktop Session Settings zu sehen?

MichaelD
White ninja
White ninja
Posts: 7
Joined: 14 Aug 2023, 18:03
Distribution: Porteus-LXDE-v2.1-x86_64

Autostart

Post#8 by MichaelD » 18 Aug 2023, 04:02

In Desktop Session Settings ist die RDP-Server.desktop zu sehen und angehakt.
Habe es jetzt mit Porteus 5.0 LXDE versucht. Es hat -auch dank deiner hilfreichen Tipps- geklappt.
Nur finde ich dort nirgends die Möglichkeit die Bildschirmauflösung dauerhaft zu ändern (Menüpunkt Display o.Ä).
Über Preferenzes -> ARandR -> Virtual1 kann ich die Auflösung nur temporär ändern. Bei Neustart sind die Einstellungen weg.
Vielleicht kannst Du mir auch dabei noch helfen.

donald
Full of knowledge
Full of knowledge
Posts: 2077
Joined: 17 Jun 2013, 13:17
Distribution: Porteus 3.2.2 XFCE 32bit
Location: Germany

Autostart

Post#9 by donald » 18 Aug 2023, 06:49

Es hat ...geklappt
:good: Was genau war denn das Problem / der Fehler?
.
Nur finde ich dort nirgends die Möglichkeit die Bildschirmauflösung dauerhaft zu ändern
Eine Möglichkeit:
In ArandR deine Einstellungen speichern.
Das erstellt ein script für xrandr in /home/guest/.screenlayout/<name>.sh

Ich nenne es mal fixscreen.sh

Nun in /.config/autostart ein fixscreen.desktop file erstellen:

Code: Select all

[Desktop Entry]
Type=Application
Name=fixscreen
Exec=/home/guest/.screenlayout/fixscreen.sh
OnlyShowIn=LXDE
Check ob es angezeigt wird in > preferences > Desktop Session Settings

Logout/login oder reboot.

MichaelD
White ninja
White ninja
Posts: 7
Joined: 14 Aug 2023, 18:03
Distribution: Porteus-LXDE-v2.1-x86_64

Autostart

Post#10 by MichaelD » 18 Aug 2023, 11:12

Super, probiere ich nachher gleich mal aus.

Ich habe zu meiner .desktop-Datei die Zeilen "Terminal=true" und "StartupNotify=true"

Seit dem klappe es mit Porteus 5.0 LXDE auch auf meinem uralten und lahmen Netbook.

MichaelD
White ninja
White ninja
Posts: 7
Joined: 14 Aug 2023, 18:03
Distribution: Porteus-LXDE-v2.1-x86_64

Autostart

Post#11 by MichaelD » 18 Aug 2023, 12:08

Ich konnte nicht widerstehen und hab Deine Tipps gleich ausprobiert. Jetzt läuft alles so, wie ich es mir gewünscht habe.
Vielen vielen Dank.

Post Reply