Porteus v5.0rc1 problems

Please reproduce your error on a second machine before posting, and check the error by running without saved changes or extra modules (See FAQ No. 13, "How to report a bug"). For unstable Porteus versions (alpha, beta, rc) please use the relevant thread in our "Development" section.
User avatar
ralcocer
Samurai
Samurai
Posts: 186
Joined: 02 Jan 2011, 12:53
Distribution: 3.2rc5 Xfce
Location: Puerto Rico
Contact:

Porteus v5.0rc1 problems

Post#136 by ralcocer » 28 Dec 2019, 14:07

Just downloaded the latest version but the Browser update tool for chrome is missing libbfd-2.26.20160125.so from binutils downloaded binutils-2.26-x86_64-3.txz from https://slackware.pkgs.org using :
"#!/bin/sh
/usr/bin/google-chrome-stable --user-data-dir=/root/chrome/user --disk-cache-dir="/root/chrome/cache" --disk-cache-size=10000000 --media-cache-size=10000000 --no-sandbox --disable-infobars "$@" "

for root access.

User avatar
ralcocer
Samurai
Samurai
Posts: 186
Joined: 02 Jan 2011, 12:53
Distribution: 3.2rc5 Xfce
Location: Puerto Rico
Contact:

Porteus v5.0rc1 problems

Post#137 by ralcocer » 29 Dec 2019, 09:01

Just downloaded the latest version of Porteus here is what I found, USM will not work, Printing does not work localhost:631 will not add the printer., create live usb says illegal iso, browser selection is missing binutil, chrome browser will run as root using this:

#!/bin/sh
/usr/bin/google-chrome-stable --user-data-dir=/root/chrome/user --disk-cache-dir="/root/chrome/cache" --disk-cache-size=10000000 --media-cache-size=10000000 --no-sandbox --disable-infobars "$@"

User avatar
Blaze
DEV Team
DEV Team
Posts: 2996
Joined: 28 Dec 2010, 11:31
Distribution: ⟰ Porteus current ☯ all DEs ☯
Location: ☭ Russian Federation, Lipetsk region, Dankov
Contact:

Porteus v5.0rc1 problems

Post#138 by Blaze » 29 Dec 2019, 10:27

ralcocer, probably I am something missing, but why you don't activate 05-devel.xzm?

Code: Select all

# find /tmp/05-devel/usr/lib64 -name *libbfd*
/tmp/05-devel/usr/lib64/libbfd.so
/tmp/05-devel/usr/lib64/libbfd.a
/tmp/05-devel/usr/lib64/libbfd-2.33.1-slack15.so
ralcocer wrote:
29 Dec 2019, 09:01
Printing does not work localhost:631
Do you use this base module 07-printing-x86_64-2019-11-12.xzm plus addition printing module for your DE (I mean Important information! Please look at this spoiler:)?
How about http://localhost:631/admin ?
What model of your printer?

Thanks.
Linux 5.4.57-porteus #1 SMP Sun Aug 9 09:03:28 UTC 2020 x86_64 Intel(R) Core(TM) i5-6600K CPU @ 3.50GHz GenuineIntel GNU/Linux
MS-7A12 » [AMD/ATI] Tobago PRO [Radeon R7 360 / R9 360 OEM] (rev 81) » Vengeance LPX 16GB DDR4 K2 3200MHz C16

User avatar
amplatfus
Samurai
Samurai
Posts: 145
Joined: 30 Oct 2012, 14:55
Distribution: MATE Porteus-v5.0rc1
Location: Romania

Porteus v5.0rc1 problems

Post#139 by amplatfus » 04 Jan 2020, 17:06

Hi all and Happy New Year,

Could you please provide some advice?

It seems that I cannot conect to OpenVPN on Porteus v5.0, Mate distribution.
I got the error that I have to instal network manager openvpn.

Thank you,
amplatfus
Porteus-v5.0. rc1 MATE. Thank you all dev team and @Blaze for helping to configure it, thanks to entire Porteus community members for great topics.
Kernel: 000-kernel-5.4.8,xzm

User avatar
Blaze
DEV Team
DEV Team
Posts: 2996
Joined: 28 Dec 2010, 11:31
Distribution: ⟰ Porteus current ☯ all DEs ☯
Location: ☭ Russian Federation, Lipetsk region, Dankov
Contact:

Porteus v5.0rc1 problems

Post#140 by Blaze » 05 Jan 2020, 08:47

amplatfus, Happy New Year!!!
I think it's extra plugin and he does not to be in the base delivery.
I builded NetworkManager-openvpn-1.8.11-x86_64-1bl.tgz for you.
Note. It's dev version b50020cc from https://gitlab.gnome.org/GNOME/NetworkManager-openvpn with applyed 0001-build-disable-libnm-glib-support-by-default.patch

Code: Select all

# Don't build against libnm-glib/gtk
patch -Np1 -i ../0001-build-disable-libnm-glib-support-by-default.patch
Image Image
Image
Linux 5.4.57-porteus #1 SMP Sun Aug 9 09:03:28 UTC 2020 x86_64 Intel(R) Core(TM) i5-6600K CPU @ 3.50GHz GenuineIntel GNU/Linux
MS-7A12 » [AMD/ATI] Tobago PRO [Radeon R7 360 / R9 360 OEM] (rev 81) » Vengeance LPX 16GB DDR4 K2 3200MHz C16

User avatar
amplatfus
Samurai
Samurai
Posts: 145
Joined: 30 Oct 2012, 14:55
Distribution: MATE Porteus-v5.0rc1
Location: Romania

Porteus v5.0rc1 problems

Post#141 by amplatfus » 05 Jan 2020, 12:36

Dear @Blaze,

Thank you for great support. I already tried and I now I have another error. Please take a look and please if you can provide support again.
I did a restart, I tried also with xzm creation option.
Image

Thank you so much,
amplatfus
Porteus-v5.0. rc1 MATE. Thank you all dev team and @Blaze for helping to configure it, thanks to entire Porteus community members for great topics.
Kernel: 000-kernel-5.4.8,xzm

User avatar
amplatfus
Samurai
Samurai
Posts: 145
Joined: 30 Oct 2012, 14:55
Distribution: MATE Porteus-v5.0rc1
Location: Romania

Porteus v5.0rc1 problems

Post#142 by amplatfus » 05 Jan 2020, 12:45

PS: I think I got that error because I have a copy only for NetworkManager files, without certificates. I will try again and update this post after.
Thank you so much!
PS2 update: I tried with import a new VPN connection, from openvpn file. It let me to configure, enter passowrd, but failed to start. Same error like in my previous post.
Could you please help me?

Thank you,
amplatfus
Porteus-v5.0. rc1 MATE. Thank you all dev team and @Blaze for helping to configure it, thanks to entire Porteus community members for great topics.
Kernel: 000-kernel-5.4.8,xzm

User avatar
Blaze
DEV Team
DEV Team
Posts: 2996
Joined: 28 Dec 2010, 11:31
Distribution: ⟰ Porteus current ☯ all DEs ☯
Location: ☭ Russian Federation, Lipetsk region, Dankov
Contact:

Porteus v5.0rc1 problems

Post#143 by Blaze » 05 Jan 2020, 16:12

amplatfus, a) do you install OpenVPN and synced your time?

Code: Select all

su
toor
getpkg openvpn
# don't forget to activate openvpn xzm module
cp /etc/localtime{,.bak} && rm /etc/localtime && ln -sf /usr/share/zoneinfo/Europe/Bucharest /etc/localtime && ntpdate pool.ntp.org && hwclock -lw
# Run daemon of OpenVPN
chmod +x /etc/rc.d/rc.openvpn
/etc/rc.d/rc.openvpn start
b) when this error is happen can you show output of:

Code: Select all

su
toor
# where client.ovpn is your client configuration file
openvpn --config /etc/openvpn/client.ovpn
tail -f /var/log/syslog
?

c) Do you have in your client configuration file /etc/openvpn/client.ovpn these options

Code: Select all

status /var/log/openvpn-status.log
log /var/log/openvpn.log
verb 9
mute 50
? d) If yes, what in /var/log/openvpn-status.log and /var/log/openvpn.log?
Linux 5.4.57-porteus #1 SMP Sun Aug 9 09:03:28 UTC 2020 x86_64 Intel(R) Core(TM) i5-6600K CPU @ 3.50GHz GenuineIntel GNU/Linux
MS-7A12 » [AMD/ATI] Tobago PRO [Radeon R7 360 / R9 360 OEM] (rev 81) » Vengeance LPX 16GB DDR4 K2 3200MHz C16

User avatar
amplatfus
Samurai
Samurai
Posts: 145
Joined: 30 Oct 2012, 14:55
Distribution: MATE Porteus-v5.0rc1
Location: Romania

Porteus v5.0rc1 problems

Post#144 by amplatfus » 05 Jan 2020, 17:41

Thank you for detailed steps.
I did one by one, and I activated downloaded module and after I tried. I tried also from VPN Connection menu near clock applet. Same error.
It seems something related to user group. Extracted from below log: Group “nm-openvpn” not found, check NM_OPENVPN_GROUP.

Thank you for helping me and If is possible, I would like some advice here too.


Thank you so much!

Code: Select all

root@porteus:/home/guest# getpkg openvpn

[OK] openvpn-2.4.8-x86_64-1.txz

Please enter a directory to download the packages to.
> Downloads

Downloading: openvpn-2.4.8-x86_64-1.txz   DONE 
Converting openvpn-2.4.8-x86_64-1.txz ...
Verifying package openvpn-2.4.8-x86_64-1.txz.
Installing package openvpn-2.4.8-x86_64-1.txz:
PACKAGE DESCRIPTION:
# openvpn (secure IP tunnel daemon)
#
......
# OpenVPN's home on the net is: http://openvpn.net
#
Executing install script for openvpn-2.4.8-x86_64-1.txz.
Package openvpn-2.4.8-x86_64-1.txz installed.
Creating /home/guest/Downloads/openvpn-2.4.8-x86_64-1.xzm


Processing finished. 
Your files are in: Downloads
root@porteus:/home/guest# cp /etc/localtime{,.bak} && rm /etc/localtime && ln -sf /usr/share/zoneinfo/Europe/Bucharest /etc/localtime && ntpdate pool.ntp.org && hwclock -lw
5 Jan 18:58:31 ntpdate[3193]: step time server 46.243.26.34 offset -7190.336821 sec
root@porteus:/home/guest# chmod +x /etc/rc.d/rc.openvpn
root@porteus:/home/guest# /etc/rc.d/rc.openvpn start
Unable to start OpenVPN - no .conf files found in /etc/openvpn/.
VPN connection: failed to connect interactively: 'Group “nm-openvpn” not found, check NM_OPENVPN_GROUP.':

Code: Select all

root@porteus:/home/guest# tail -f /var/log/syslog
Jan  5 18:41:30 porteus pulseaudio[1268]: [alsa-sink-ALC293 Analog] alsa-sink.c: Most likely this is a bug in the ALSA driver 'snd_hda_intel'. Please report this issue to the ALSA developers.
Jan  5 18:41:30 porteus pulseaudio[1268]: [alsa-sink-ALC293 Analog] alsa-sink.c: We were woken up with POLLOUT set -- however a subsequent snd_pcm_avail() returned 0 or another value < min_avail.
Jan  5 18:57:35 porteus NetworkManager[1062]: <warn>  [1578250655.4517] vpn-connection[0x25d4160,dd696686-d8b4-4757-9b74-4b527b134ae8,"client1_500",0]: VPN connection: failed to connect interactively: 'Group “nm-openvpn” not found, check NM_OPENVPN_GROUP.'
Jan  5 19:00:48 porteus NetworkManager[1062]: <warn>  [1578243648.5759] vpn-connection[0x25d4370,33cc461f-e973-4406-bc94-cea113f3129b,"client1guest",0]: VPN connection: failed to connect interactively: 'Group “nm-openvpn” not found, check NM_OPENVPN_GROUP.'
Jan  5 19:01:03 porteus NetworkManager[1062]: <warn>  [1578243663.4091] vpn-connection[0x25d4580,dd696686-d8b4-4757-9b74-4b527b134ae8,"client1_500",0]: VPN connection: failed to connect interactively: 'Group “nm-openvpn” not found, check NM_OPENVPN_GROUP.'
Jan  5 19:05:33 porteus NetworkManager[1062]: <warn>  [1578243933.8914] vpn-connection[0x25d4790,3b251663-8e3c-4c98-9816-d9448dfec92b,"client1fl",0]: VPN connection: failed to connect interactively: 'Group “nm-openvpn” not found, check NM_OPENVPN_GROUP.'
Jan  5 19:13:22 porteus NetworkManager[1062]: <warn>  [1578244402.3403] sup-iface[0x2542820,wlan0]: connection disconnected (reason -3)
Jan  5 19:13:39 porteus NetworkManager[1062]: <warn>  [1578244419.5326] vpn-connection[0x25d4790,f29a0fe5-c45a-4dc2-8799-7712b6c95a60,"client1-msnc",0]: VPN connection: failed to connect interactively: 'Group “nm-openvpn” not found, check NM_OPENVPN_GROUP.'
Jan  5 19:14:02 porteus NetworkManager[1062]: <warn>  [1578244442.9530] vpn-connection[0x25d4580,f29a0fe5-c45a-4dc2-8799-7712b6c95a60,"client1-msnc",0]: VPN connection: failed to connect interactively: 'Group “nm-openvpn” not found, check NM_OPENVPN_GROUP.'
Jan  5 19:14:23 porteus NetworkManager[1062]: <warn>  [1578244463.5297] vpn-connection[0x25d4370,f29a0fe5-c45a-4dc2-8799-7712b6c95a60,"client1-msnc",0]: VPN connection: failed to connect interactively: 'Group “nm-openvpn” not found, check NM_OPENVPN_GROUP.'
Porteus-v5.0. rc1 MATE. Thank you all dev team and @Blaze for helping to configure it, thanks to entire Porteus community members for great topics.
Kernel: 000-kernel-5.4.8,xzm

User avatar
Blaze
DEV Team
DEV Team
Posts: 2996
Joined: 28 Dec 2010, 11:31
Distribution: ⟰ Porteus current ☯ all DEs ☯
Location: ☭ Russian Federation, Lipetsk region, Dankov
Contact:

Porteus v5.0rc1 problems

Post#145 by Blaze » 05 Jan 2020, 18:00

amplatfus, well, seems openvpn-2.4.8-x86_64-1.txz does not need (only for server)
You will need an "nm-openvpn" user and group to use this. Suggested:

Code: Select all

su
toor
groupadd -g 320 nm-openvpn
useradd -u 320 -g nm-openvpn -d /var/lib/openvpn/chroot -s /bin/false nm-openvpn
Linux 5.4.57-porteus #1 SMP Sun Aug 9 09:03:28 UTC 2020 x86_64 Intel(R) Core(TM) i5-6600K CPU @ 3.50GHz GenuineIntel GNU/Linux
MS-7A12 » [AMD/ATI] Tobago PRO [Radeon R7 360 / R9 360 OEM] (rev 81) » Vengeance LPX 16GB DDR4 K2 3200MHz C16

AcnapyxoB
Black ninja
Black ninja
Posts: 42
Joined: 24 Dec 2014, 10:15
Distribution: 4.0 XFCE x64
Location: Bulgaria

Porteus v5.0rc1 problems

Post#146 by AcnapyxoB » 05 Jan 2020, 18:39

Happy New Year :beer:
I apologize for the intervention
For me OpenVPN is working fine from terminal:

- Generate keys and certificates (I think Iou have them)
- Modify client.conf (or any other name) in /etc/openvpn

example client.conf:

Code: Select all

client
remote [IP ADDRESS]
ca /etc/openvpn/certs/ca.crt
cert /etc/openvpn/certs/ovpn3.crt
key /etc/openvpn/keys/ovpn3.key
dh /etc/openvpn/keys/dh.pem
cipher AES-256-CBC
dev tun0
proto udp
port 1194 #or any other
redirect-gateway
remote-cert-tls server
resolv-retry infinite
nobind
auth-nocache
persist-key
persist-tun
mute-replay-warnings
mute 20
float
- run:

Code: Select all

su
toor
openvpn /etc/openvpn/client.conf

User avatar
amplatfus
Samurai
Samurai
Posts: 145
Joined: 30 Oct 2012, 14:55
Distribution: MATE Porteus-v5.0rc1
Location: Romania

Porteus v5.0rc1 problems

Post#147 by amplatfus » 05 Jan 2020, 19:05

Dear @Blaze and Dear @AcnapyxoB,

Thank you both.
In the meantime I tested what @Blaze send last time and is working.
As obervation is working with only

Code: Select all

groupadd -g 320 nm-openvpn
or

Code: Select all

useradd -u 320 -g nm-openvpn -d /var/lib/openvpn/chroot -s /bin/false nm-openvpn
Even without command below (I know I need a correct hh:mm) :

Code: Select all

cp /etc/localtime{,.bak} && rm /etc/localtime && ln -sf /usr/share/zoneinfo/Europe/Bucharest /etc/localtime && ntpdate pool.ntp.org && hwclock -lw
And also without openvpn-2.4.8-x86_64-1.xzm active, but NetworkManager-openvpn-1.8.11-x86_64-1bl.xzm active.
Just boot on fresh Porteus :) with NetworkManager-openvpn-1.8.11-x86_64-1bl.xzm active and enter this under root (groupadd -g 320 nm-openvpn) or this (useradd -u 320 -g nm-openvpn -d /var/lib/openvpn/chroot -s /bin/false nm-openvpn), but not both, because I obtain this:

Code: Select all

guest@porteus:~$ su
Password: 
root@porteus:/home/guest# groupadd -g 320 nm-openvpn
root@porteus:/home/guest# useradd -u 320 -g nm-openvpn -d /var/lib/openvpn/chroot -s /bin/false nm-openvpn
useradd: user 'nm-openvpn' already exists
I wrote so much details, maybe it will belp others or for futher reference.
Thank you both.

Now, the next step I tried to put the command in rc.local, but it not worked.
If you have any suggestion, please share here.

Thank you again,
amplatfus


PS Edit1: I solved with rc.local after I saved both command there like @Blaze said:

Code: Select all

groupadd -g 320 nm-openvpn
useradd -u 320 -g nm-openvpn -d /var/lib/openvpn/chroot -s /bin/false nm-openvpn
Porteus-v5.0. rc1 MATE. Thank you all dev team and @Blaze for helping to configure it, thanks to entire Porteus community members for great topics.
Kernel: 000-kernel-5.4.8,xzm

User avatar
Blaze
DEV Team
DEV Team
Posts: 2996
Joined: 28 Dec 2010, 11:31
Distribution: ⟰ Porteus current ☯ all DEs ☯
Location: ☭ Russian Federation, Lipetsk region, Dankov
Contact:

Porteus v5.0rc1 problems

Post#148 by Blaze » 05 Jan 2020, 19:51

amplatfus wrote:
05 Jan 2020, 19:05
And also without openvpn-2.4.8-x86_64-1.xzm active
activate openvpn-2.4.8-x86_64-1.xzm + NetworkManager-openvpn-1.8.11-x86_64-1bl.xzm modules and

Code: Select all

su
toor
groupadd -g 320 nm-openvpn
useradd -u 320 -g nm-openvpn -d /var/lib/openvpn/chroot -s /bin/false nm-openvpn
all commands should work correctly. After this I checked the correctness at my PC

Code: Select all

# id nm-openvpn
uid=320(nm-openvpn) gid=320(nm-openvpn) groups=320(nm-openvpn)

# groups nm-openvpn
nm-openvpn : nm-openvpn
:thumbsup:
Linux 5.4.57-porteus #1 SMP Sun Aug 9 09:03:28 UTC 2020 x86_64 Intel(R) Core(TM) i5-6600K CPU @ 3.50GHz GenuineIntel GNU/Linux
MS-7A12 » [AMD/ATI] Tobago PRO [Radeon R7 360 / R9 360 OEM] (rev 81) » Vengeance LPX 16GB DDR4 K2 3200MHz C16

User avatar
amplatfus
Samurai
Samurai
Posts: 145
Joined: 30 Oct 2012, 14:55
Distribution: MATE Porteus-v5.0rc1
Location: Romania

Porteus v5.0rc1 problems

Post#149 by amplatfus » 05 Jan 2020, 20:24

Thank you so much! In my case is working even without openvpn-1.8.11-x86_64-1bl.xzm module active.
:punk:
Porteus-v5.0. rc1 MATE. Thank you all dev team and @Blaze for helping to configure it, thanks to entire Porteus community members for great topics.
Kernel: 000-kernel-5.4.8,xzm

User avatar
amplatfus
Samurai
Samurai
Posts: 145
Joined: 30 Oct 2012, 14:55
Distribution: MATE Porteus-v5.0rc1
Location: Romania

Porteus v5.0rc1 problems

Post#150 by amplatfus » 06 Jan 2020, 08:40

Dear Community,

Now I have another situation regarding Samba and mount network folder from Asus Router (external USB HDD) to local Porteus Mate 5.0. On router I have activated SMB version 2 and 1.
If I try to connect without specify vers=1.0 I have entry in messages and in syslog.
If I specify vers=1.0 I have entry only in messages.
Below you can find commands and output.

Please, if you have any suggestion, share it here. If I will find something, I will update this post.

Thank you so much,
amplatfus

Code: Select all

root@porteus:/home/guest# mount.cifs //192.168.0.1/pc /mnt/pc --verbose -o username=user,password=pass
mount.cifs kernel mount options: ip=192.168.0.1,unc=\\192.168.0.1\pc,user=user,pass=****
mount error(22): Invalid argument
Refer to the mount.cifs(8) manual page (e.g. man mount.cifs) and kernel log messages (dmesg)

root@porteus:/home/guest# tail -f /var/log/messages
Jan  6 10:24:51 porteus kernel: [ 4428.226839] CIFS: Attempting to mount //192.168.0.1/pc

root@porteus:/home/guest# tail -f /var/log/syslog
Jan  6 10:24:51 porteus kernel: [ 4428.226949] No dialect specified on mount. Default has changed to a more secure dialect, SMB2.1 or later (e.g. SMB3), from CIFS (SMB1). To use the less secure SMB1 dialect to access old servers which do not support SMB3 (or SMB2.1) specify vers=1.0 on mount.


root@porteus:/home/guest# mount.cifs //192.168.0.1/pc /mnt/pc --verbose -o username=user,password=pass,vers=1.0
mount.cifs kernel mount options: ip=192.168.0.1,unc=\\192.168.0.1\pc,user=user,pass=****
mount error(22): Invalid argument
Refer to the mount.cifs(8) manual page (e.g. man mount.cifs) and kernel log messages (dmesg)

root@porteus:/home/guest# tail -f /var/log/messages
#new row here now, when I used vers=1.0 in mount command
Jan  6 10:26:07 porteus kernel: [ 4803.665314] CIFS: Attempting to mount //192.168.0.1/pc


root@porteus:/home/guest# tail -f /var/log/syslog
#nothing new here now, when I used vers=1.0 in mount command
Jan  6 10:24:51 porteus kernel: [ 4428.226949] No dialect specified on mount. Default has changed to a more secure dialect, SMB2.1 or later (e.g. SMB3), from CIFS (SMB1). To use the less secure SMB1 dialect to access old servers which do not support SMB3 (or SMB2.1) specify vers=1.0 on mount. [\code]
Porteus-v5.0. rc1 MATE. Thank you all dev team and @Blaze for helping to configure it, thanks to entire Porteus community members for great topics.
Kernel: 000-kernel-5.4.8,xzm

Post Reply