Porteus v5.0rc1 problems

Please reproduce your error on a second machine before posting, and check the error by running without saved changes or extra modules (See FAQ No. 13, "How to report a bug"). For unstable Porteus versions (alpha, beta, rc) please use the relevant thread in our "Development" section.
jssouza
DEV Team
DEV Team
Posts: 1165
Joined: 09 Jul 2015, 14:17
Distribution: Porteus x86 arm

Porteus v5.0rc1 problems

Post#166 by jssouza » 22 Jan 2020, 23:55

sean, without much debug info to go on, this could be either of two things:
1. Your network controller does not like broadcom's open source drivers, but only needs the proprietary 'wl' driver, which is not provided by Porteus anymore.
Or,
2. An open source driver has been loaded but the firmware is missing.

Run the command lspci -knn to check what driver is being used. If the same driver has been loaded on both Porteus as well as MX-19, check on MX-19 if a firmware has been loaded. If yes, (looks like most issues for your hardware is a problem with missing firmware) check in /lib/firmware if the loaded firmware on MX-19 is missing on Porteus. Copy the firmware to /lib/firmware and check if internet then works.

For case 1: You could try using an older kernel where Porteus was still shipping broadcom wl (I believe it was during Porteus 3.2.2).

Good luck.

sean
Contributor
Contributor
Posts: 150
Joined: 08 Jul 2012, 02:30
Distribution: Porteus v3.0 LXDE i486
Location: South Central PA, USA

Porteus v5.0rc1 problems

Post#167 by sean » 23 Jan 2020, 04:22

Thanks for your kind reply Ed_P, great to see you are still here!,

And "jssouza", thank you also for your kind reply's to my recent posts :-),

Gentlemen,

I only submitted the problem for Porteus development info & "consideration as an unsolved bug". I fully realize this computer is now fairly ancient. I just thought the developers here might desire that information. Also I see here that Broadcom has been a PIA for Linux/Wifi for some considerable time. There is certainly a limit to Porteus long term compatibility/support. Obviously this is such a time for me/us and this computer.

With that in mind, "jssouza", I will skip this computer and move on. Porteus (wifi) working on this Dell is not a priority. ( I don't like the dang thing anyway :-)

However, should you, as a Porteus Developer, wish to pursue this matter I will be most happy to oblige and supply any information you may request , and which I am proficient to provide.

"jssouza", your interest, is deeply appreciated,

sean

jssouza
DEV Team
DEV Team
Posts: 1165
Joined: 09 Jul 2015, 14:17
Distribution: Porteus x86 arm

Porteus v5.0rc1 problems

Post#168 by jssouza » 23 Jan 2020, 04:51

sean as root, please provide outputs of these commands:
lspci -knn
lsmod
dmesg | grep firmware

sean
Contributor
Contributor
Posts: 150
Joined: 08 Jul 2012, 02:30
Distribution: Porteus v3.0 LXDE i486
Location: South Central PA, USA

Porteus v5.0rc1 problems

Post#169 by sean » 23 Jan 2020, 14:51

jssouza, as you requested, here are the outputs of the 3 commands. The third "dmesg grep | firmware gave no output. I hope this is helpful to you and Porteus.

Code: Select all

root@porteus:~# lspci -knn
00:00.0 Host bridge [0600]: Intel Corporation Mobile 4 Series Chipset Memory Controller Hub [8086:2a40] (rev 07)
	Subsystem: Dell Device [1028:02cf]
	Kernel modules: intel_agp
00:02.0 VGA compatible controller [0300]: Intel Corporation Mobile 4 Series Chipset Integrated Graphics Controller [8086:2a42] (rev 07)
	Subsystem: Dell Device [1028:02cf]
	Kernel driver in use: i915
	Kernel modules: i915
00:02.1 Display controller [0380]: Intel Corporation Mobile 4 Series Chipset Integrated Graphics Controller [8086:2a43] (rev 07)
	Subsystem: Dell Device [1028:02cf]
00:1a.0 USB controller [0c03]: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #4 [8086:2937] (rev 03)
	Subsystem: Dell Device [1028:02cf]
	Kernel driver in use: uhci_hcd
00:1a.1 USB controller [0c03]: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #5 [8086:2938] (rev 03)
	Subsystem: Dell Device [1028:02cf]
	Kernel driver in use: uhci_hcd
00:1a.2 USB controller [0c03]: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #6 [8086:2939] (rev 03)
	Subsystem: Dell Device [1028:02cf]
	Kernel driver in use: uhci_hcd
00:1a.7 USB controller [0c03]: Intel Corporation 82801I (ICH9 Family) USB2 EHCI Controller #2 [8086:293c] (rev 03)
	Subsystem: Dell Device [1028:02cf]
	Kernel driver in use: ehci-pci
00:1b.0 Audio device [0403]: Intel Corporation 82801I (ICH9 Family) HD Audio Controller [8086:293e] (rev 03)
	Subsystem: Dell Device [1028:02cf]
	Kernel driver in use: snd_hda_intel
	Kernel modules: snd_hda_intel
00:1c.0 PCI bridge [0604]: Intel Corporation 82801I (ICH9 Family) PCI Express Port 1 [8086:2940] (rev 03)
	Kernel driver in use: pcieport
00:1c.1 PCI bridge [0604]: Intel Corporation 82801I (ICH9 Family) PCI Express Port 2 [8086:2942] (rev 03)
	Kernel driver in use: pcieport
00:1c.2 PCI bridge [0604]: Intel Corporation 82801I (ICH9 Family) PCI Express Port 3 [8086:2944] (rev 03)
	Kernel driver in use: pcieport
00:1c.4 PCI bridge [0604]: Intel Corporation 82801I (ICH9 Family) PCI Express Port 5 [8086:2948] (rev 03)
	Kernel driver in use: pcieport
00:1d.0 USB controller [0c03]: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #1 [8086:2934] (rev 03)
	Subsystem: Dell Device [1028:02cf]
	Kernel driver in use: uhci_hcd
00:1d.1 USB controller [0c03]: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #2 [8086:2935] (rev 03)
	Subsystem: Dell Device [1028:02cf]
	Kernel driver in use: uhci_hcd
00:1d.2 USB controller [0c03]: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #3 [8086:2936] (rev 03)
	Subsystem: Dell Device [1028:02cf]
	Kernel driver in use: uhci_hcd
00:1d.7 USB controller [0c03]: Intel Corporation 82801I (ICH9 Family) USB2 EHCI Controller #1 [8086:293a] (rev 03)
	Subsystem: Dell Device [1028:02cf]
	Kernel driver in use: ehci-pci
00:1e.0 PCI bridge [0604]: Intel Corporation 82801 Mobile PCI Bridge [8086:2448] (rev 93)
00:1f.0 ISA bridge [0601]: Intel Corporation ICH9M LPC Interface Controller [8086:2919] (rev 03)
	Subsystem: Dell Device [1028:02cf]
	Kernel driver in use: lpc_ich
	Kernel modules: lpc_ich
00:1f.2 SATA controller [0106]: Intel Corporation 82801IBM/IEM (ICH9M/ICH9M-E) 4 port SATA Controller [AHCI mode] [8086:2929] (rev 03)
	Subsystem: Dell Device [1028:02cf]
	Kernel driver in use: ahci
00:1f.3 SMBus [0c05]: Intel Corporation 82801I (ICH9 Family) SMBus Controller [8086:2930] (rev 03)
	Subsystem: Dell Device [1028:02cf]
	Kernel driver in use: i801_smbus
	Kernel modules: i2c_i801
09:00.0 Ethernet controller [0200]: Realtek Semiconductor Co., Ltd. RTL8101/2/6E PCI Express Fast/Gigabit Ethernet controller [10ec:8136] (rev 02)
	Subsystem: Dell Device [1028:02cf]
	Kernel driver in use: r8169
	Kernel modules: r8169
0c:00.0 Network controller [0280]: Broadcom Corporation BCM4312 802.11b/g LP-PHY [14e4:4315] (rev 01)
	Subsystem: Dell Wireless 1397 WLAN Mini-Card [1028:000c]
	Kernel modules: ssb
root@porteus:~# 

Code: Select all

root@porteus:~# lsmod
Module                  Size  Used by
ipv6                  335872  12
uvcvideo               90112  0
videobuf2_vmalloc      16384  1 uvcvideo
videobuf2_memops       16384  1 videobuf2_vmalloc
videobuf2_v4l2         24576  1 uvcvideo
videobuf2_common       36864  2 videobuf2_v4l2,uvcvideo
dcdbas                 16384  0
dell_smm_hwmon         16384  0
i915                 1363968  6
coretemp               16384  0
snd_hda_codec_idt      53248  1
input_leds             16384  0
snd_hda_codec_generic    61440  1 snd_hda_codec_idt
i2c_i801               24576  0
led_class              16384  1 input_leds
ledtrig_audio          16384  1 snd_hda_codec_generic
snd_hda_intel          32768  3
r8169                  65536  0
snd_hda_codec          94208  3 snd_hda_codec_generic,snd_hda_intel,snd_hda_codec_idt
realtek                20480  1
lpc_ich                28672  0
snd_hda_core           53248  4 snd_hda_codec_generic,snd_hda_intel,snd_hda_codec,snd_hda_codec_idt
intel_agp              20480  0
snd_hwdep              16384  1 snd_hda_codec
intel_gtt              20480  2 intel_agp,i915
libphy                 57344  2 r8169,realtek
snd_pcm                73728  3 snd_hda_intel,snd_hda_codec,snd_hda_core
snd_timer              28672  1 snd_pcm
wmi                    20480  0
pcc_cpufreq            16384  0
acpi_cpufreq           16384  1
root@porteus:~# 

Code: Select all

root@porteus:~# dmesg | grep firmware
root@porteus:~# dmesg | grep firmware
root@porteus:~# dmesg | grep firmware
root@porteus:~# 

sean

User avatar
Rava
Contributor
Contributor
Posts: 2480
Joined: 11 Jan 2011, 02:46
Distribution: Porteus 5.0rc1 x86-64 XFCe
Location: Forests of Germany

Porteus v5.0rc1 problems

Post#170 by Rava » 04 Feb 2020, 01:05

For some reason, the md5sums file http://dl.porteus.org/x86_64/Porteus-v5.0/md5sums.txt is missing all files in the kernel/ subfolder.
I would like to confirm if these are correct:

Code: Select all

cdf3057c0f6902820cea089e485df6ef  05-devel.xzm
1954ff4acbfbb95dd47d6d3634813a76  06-crippled_sources-5.1.5-64bit.xzm
_______________________________________________

Another issue. Unlike older 5.0rc1 versions, the VT resolution (VT=virtual terminal, the text terminals you work with when not starting X, e.g. when you want to compile NVIDIA drivers for older hardware) is quite ugly on my full HD screen. See for yourself:
Image

The reason is quite simple: It is a notebook and the Full-HD screen is an external HDMI monitor (and its resolution is sure 1920x1080, or it would not be a full-HD monitor), the resolution of the internal screen is a mere 1366x768.
So, the mc displayed in the screenshot using only a small part of the full HD monitor; the very same mc displayed on the internal monitor is shown as full-screen without any waste at the borders on the 1366x768 resolution.
And besides, I need to really move too close for comfort to the full-HD monitor to even read what's there. :(

Since I tend to work with the external monitor, I would like to have a more sane resolution than the one displayed in the screenshot.
Why was that changed? I really did preferred the "boring, more normal" 80x25 columns and rows of the older 5.0rc1 versions, since these look well on a Full-HD screen and on the internal screen.

____________________________________

uloop has the very same bug I already reported some time prior the release of "porteus-5.0rc1-x86_64.iso 26-May-2019", it reports umounting when in reality the umount failed:

Code: Select all

root@porteus:/mnt/loop/var/log/packages# ls -o
total 14
-rw-r--r-- 1 root 10015 Jul  9  2019 gsettings-desktop-schemas-3.28.1-i586-1
-rw-r--r-- 1 root  3777 Jul  9  2019 peek-git-1d3e971-x86_64-ncm
root@porteus:/mnt/loop/var/log/packages# uloop
umount: /mnt/loop: target is busy.

/mnt/loop has been unmounted

root@porteus:/mnt/loop/var/log/packages# echo $?
0
root@porteus:/mnt/loop/var/log/packages# ls -o
total 14
-rw-r--r-- 1 root 10015 Jul  9  2019 gsettings-desktop-schemas-3.28.1-i586-1
-rw-r--r-- 1 root  3777 Jul  9  2019 peek-git-1d3e971-x86_64-ncm
As you can see, uloop reports "/mnt/loop has been unmounted" and returns "0" as return value indicating all went well, when in reality it should report "/mnt/loop has NOT been unmounted", and also return a non-zero value.
Cheers!
Yours Rava

User avatar
babam
Black ninja
Black ninja
Posts: 91
Joined: 16 Nov 2016, 10:30
Distribution: Porteus Xfce 3.2.2
Location: Rainy city

Porteus v5.0rc1 problems

Post#171 by babam » 23 Mar 2020, 15:55

Please to add Trash support on VFAT and NTFS filesystem.

Code: Select all

$ gio trash /path/to/fileordirectory

Code: Select all

 --- old/finit
+++ new/finit
@@ -51,11 +51,11 @@
 EOF
 for x in $dev; do
     fs=`grep -w /dev/$x /tmp/devices | egrep -o ' TYPE=[^ ]+' | cut -d'"' -f2`
-    [ $fs = vfat ] && echo "/dev/$x /mnt/$x vfat $MOPT,umask=0,check=s,utf8 0 0" >>/etc/fstab || echo "/dev/$x /mnt/$x $fs $MOPT 0 0" >>/etc/fstab
+    [ $fs = vfat ] && echo "/dev/$x /mnt/$x vfat $MOPT,umask=0,check=s,utf8,uid=1000 0 0" >>/etc/fstab || echo "/dev/$x /mnt/$x $fs $MOPT 0 0" >>/etc/fstab
     if [ ! -d /mnt/$x ]; then
 	mkdir /mnt/$x
 	if [ $fs = ntfs ]; then
-	    ntfs-3g /dev/$x /mnt/$x -o $MOPT 2>/dev/null || { sed -i "/$x /d" /etc/fstab; rmdir /mnt/$x; }
+	    ntfs-3g /dev/$x /mnt/$x -o $MOPT,uid=1000,big_writes 2>/dev/null || { sed -i "/$x /d" /etc/fstab; rmdir /mnt/$x; }
 	else
 	    mount -n /mnt/$x 2>/dev/null || { modprobe $fs 2>/dev/null && mount -n /mnt/$x 2>/dev/null || { sed -i "/$x /d" /etc/fstab; rmdir /mnt/$x; }; }
 	fi
@@ -73,9 +73,9 @@
 if [ "$fs" ]; then
     mkdir /mnt/$1
     if [ $fs = vfat ]; then
-	mount -n /dev/$1 /mnt/$1 -o $MOPT,umask=0,check=s,utf8 2>/dev/null || rmdir /mnt/$1
+	mount -n /dev/$1 /mnt/$1 -o $MOPT,umask=0,check=s,utf8,uid=1000 2>/dev/null || rmdir /mnt/$1
     elif [ $fs = ntfs ]; then
-	ntfs-3g /dev/$1 /mnt/$1 -o $MOPT 2>/dev/null || rmdir /mnt/$1
+	ntfs-3g /dev/$1 /mnt/$1 -o $MOPT,uid=1000,big_writes 2>/dev/null || rmdir /mnt/$1
     else
 	mount -n /dev/$1 /mnt/$1 -o $MOPT 2>/dev/null || { modprobe $fs 2>/dev/null && mount -n /dev/$1 /mnt/$1 -o $MOPT || rmdir /mnt/$1; }
     fi
Sorry, my English is bad.

User avatar
Blaze
DEV Team
DEV Team
Posts: 2949
Joined: 28 Dec 2010, 11:31
Distribution: ⟰ Porteus current ☯ all DEs ☯
Location: ☭ Russian Federation, Lipetsk region, Dankov
Contact:

Porteus v5.0rc1 problems

Post#172 by Blaze » 23 Mar 2020, 16:33

babam, thanks, I applied your patch for initrd :hi:
Linux 5.4.57-porteus #1 SMP Sun Aug 9 09:03:28 UTC 2020 x86_64 Intel(R) Core(TM) i5-6600K CPU @ 3.50GHz GenuineIntel GNU/Linux
MS-7A12 » [AMD/ATI] Tobago PRO [Radeon R7 360 / R9 360 OEM] (rev 81) » Vengeance LPX 16GB DDR4 K2 3200MHz C16

lvds
Ronin
Ronin
Posts: 1
Joined: 23 Mar 2020, 17:01
Distribution: porteus

Porteus v5.0rc1 problems

Post#173 by lvds » 27 Mar 2020, 16:26

Hello,

I'm new to the forum and registered to report bugs found in Porteus v5.0rc1 though it seems to have already been reported by others in this thread or elsewhere in the forum because I could not make it work despite previous answers.

When using USM graphic tool, the databases updates fine and all is good, but in the end the windows empty itself (just like if someone was pressing the enter key when you have a terminal open) and at the bottom left of the windows a message says "Segmentation fault" and there is a terminal prompt #. When running usm -u all in a terminal as root all is fine.

Porteus is great and I really LOVE it ! I hope you will debug it and I can't wait having the next release. I would like to have more SFS files ready to download (LibreOffice, Thunderbird, Teamviewer, gimp, inkscape, pinta, dia, ...)

Laurent

User avatar
Ed_P
Contributor
Contributor
Posts: 5545
Joined: 06 Feb 2013, 22:12
Distribution: 4.0 Cinnamon 64-bit ISO
Location: Western NY, USA

Porteus v5.0rc1 problems

Post#174 by Ed_P » 27 Mar 2020, 17:04

To the best of my knowledge USM is not supported in 5.0rc1 at this point. Hopefully 5.0rc2 will have it and many more SFS files to download.
Last edited by Ed_P on 07 Apr 2020, 04:29, edited 1 time in total.
Reason: Can't find brokenman's statement to the fact.
Ed

User avatar
Rava
Contributor
Contributor
Posts: 2480
Joined: 11 Jan 2011, 02:46
Distribution: Porteus 5.0rc1 x86-64 XFCe
Location: Forests of Germany

Porteus v5.0rc1 problems

Post#175 by Rava » 29 Mar 2020, 14:01

Affected system is: Dual Pentium PC with Porteus 5.0rc1 and kernel 5.4.19.

While trying the so far failed attempt at compiling Nvidia driver 304.137 for Porteus 5.0rc and kernel 5.4.19 every time I opened a XFCE terminal I got this error:

Code: Select all

gnome-keyring-daemon: insufficient process capabilities, insecure memory might get used
That never occurred on my other machine which now runs 5.0rc1 successfully for ages (at least it feels like ages, with all the ongoing current weirdness in RL)

Any idea what I can do to further examine this issue?
Cheers!
Yours Rava

fulalas
DEV Team
DEV Team
Posts: 1551
Joined: 26 Oct 2016, 15:34
Distribution: Porteus
Location: Brazil

Porteus v5.0rc1 problems

Post#176 by fulalas » 29 Mar 2020, 19:27

@Rava, let me know if this Xfce module fixes your issue: http://www.mediafire.com/file/mmnd2jeq4 ... rteus5.xzm

User avatar
Rava
Contributor
Contributor
Posts: 2480
Joined: 11 Jan 2011, 02:46
Distribution: Porteus 5.0rc1 x86-64 XFCe
Location: Forests of Germany

Porteus v5.0rc1 problems

Post#177 by Rava » 29 Mar 2020, 22:28

fulalas wrote:
29 Mar 2020, 19:27
@Rava, let me know if this Xfce module fixes your issue: http://www.mediafire.com/file/mmnd2jeq4 ... rteus5.xzm
It is already the one I was using, here the md5sum:

Code: Select all

f2a9742af5cbf0344445be25eb32c598  porteus/base/003-xfce-porteus5.xzm
Cheers!
Yours Rava

fulalas
DEV Team
DEV Team
Posts: 1551
Joined: 26 Oct 2016, 15:34
Distribution: Porteus
Location: Brazil

Porteus v5.0rc1 problems

Post#178 by fulalas » 30 Mar 2020, 02:02

Alright. Could you please provide the exact and most simple step by step to reproduce the issue? And I mean, since the boot.

User avatar
Rava
Contributor
Contributor
Posts: 2480
Joined: 11 Jan 2011, 02:46
Distribution: Porteus 5.0rc1 x86-64 XFCe
Location: Forests of Germany

Porteus v5.0rc1 problems

Post#179 by Rava » 30 Mar 2020, 06:54

fulalas wrote:
30 Mar 2020, 02:02
Alright. Could you please provide the exact and most simple step by step to reproduce the issue? And I mean, since the boot.
I set up a new Porteus system: for 5.0rc1-pre-rc2 and kernel 5.4.19
I booted via cheatcode "3".
I log into the virtual console as guest. [I do not recall if I got this error in VT as well or only in the xterms, when I start up that machine again I will log into a new VT and then tell you]
I start X via "startx"
In XFCE I open xfce4-terminal.
I get the error as mentioned.

I do the same with my current 8-core running system: I also boot with "3" cheatcode, also log into a VT as guest and also start X manually via startx.
but I do not get the error in xfce4-terminal.
Cheers!
Yours Rava

User avatar
chromer
Black ninja
Black ninja
Posts: 31
Joined: 13 Jan 2019, 18:00
Distribution: APorteus Cinnamon 64bit
Location: Turkey

Porteus v5.0rc1 problems

Post#180 by chromer » 31 Mar 2020, 11:05

Hi, Is it possible to develop a tool for updating current released Porteus ISOs ?
Something like Aporteus ISO Builder by neko which update all modules of ISO automatically.
That's because the span between Porteus new releases is too long and ISO become outdated so with such tool anyone can update ISO modules , packages and use generated daily updated ISO.
Thabks very much.

Post Reply